Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] More newbie question: --hostfile option
From: Ralph Castain (rhc_at_[hidden])
Date: 2011-01-12 21:36:50


On Jan 12, 2011, at 7:23 PM, Tena Sakai wrote:

> Hi,
>
> I can execute the command below:
> $ mpirun -H vixen -np 1 hostname : -H compute-0-0,compute-0-1,compute-0-2 -np 3 hostname
> and I get:
> vixen.egcrc.org
> compute-0-0.local
> compute-0-1.local
> compute-0-2.local
>
> I have a file myhosts, which looks like:
> compute-0-0 slots=1
> compute-0-1 slots=1
> compute-0-2 slots=1
> but when I execute:
> $ mpirun -H vixen -np 1 hostname : --hostfile myhosts -np 3 hostname
> I get:
> There are no allocated resources for the application
> hostname
> that match the requested mapping:
>
> Verify that you have mapped the allocated resources properly using the
> --host or --hostfile specification.
> --------------------------------------------------------------------------
> --------------------------------------------------------------------------
> A daemon (pid unknown) died unexpectedly on signal 1 while attempting to
> launch so we are aborting.
>
> There may be more information reported by the environment (see above).
>
> This may be because the daemon was unable to find all the needed shared
> libraries on the remote node. You may set your LD_LIBRARY_PATH to have the
> location of the shared libraries on the remote nodes and this will
> automatically be forwarded to the remote nodes.
> --------------------------------------------------------------------------
> --------------------------------------------------------------------------
> mpirun noticed that the job aborted, but has no info as to the process
> that caused that situation.
> --------------------------------------------------------------------------
> mpirun: clean termination accomplished
>
> Interestingly, this works:
> $ mpirun --hostfile myhosts -np 3 hostname
> compute-0-0.local
> compute-0-1.local
> compute-0-2.local
> $
>
> Am I correct in concluding that –H and —hostfile cannot be issued in the
> same mpirun command which contains a colon (:)?

It may depend on what version of OMPI you are using. Given what you see, the answer is "correct".

> Or is there any trick
> or work-around to have both –H and —hostfile?

See the wiki page for an explanation of how the options are used:

https://svn.open-mpi.org/trac/ompi/wiki/HostFilePlan

>
> Thank you.
>
> Tena Sakai
> tsakai_at_[hidden]
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users