Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] v1.5.1: configuration failed if compiling on CentOS 5.5 with defauld GCC
From: Paul Kapinos (kapinos_at_[hidden])
Date: 2011-01-04 08:51:21


Dear OpenMPI folks,

I tried to compile the OpenMPI version 1.5.1 on a CentOS 5.5 computer
with the default GCC shipped with the distribution, which is

gcc version 4.1.2 20080704 (Red Hat 4.1.2-48)

The configuration failed:

....
configure:156412: checking location of libltdl
configure:156425: result: internal copy
configure:156709: WARNING: Failed to build GNU libltdl. This usually
means that something
configure:156711: WARNING: is incorrectly setup with your environment.
There may be useful information in
configure:156713: WARNING: opal/libltdl/config.log. You can also
disable GNU libltdl, which will disable
configure:156715: WARNING: dynamic shared object loading, by configuring
with --disable-dlopen.
configure:156717: error: Cannot continue

The configuration line was was follows:

$ ./configure --with-openib --with-devel-headers
--enable-contrib-no-build=vt --enable-mpi-threads CFLAGS=-O3 -ffast-math
-mtune=opteron -m32 CXXFLAGS=-O3 -ffast-math -mtune=opteron -m32
FFLAGS=-O3 -ffast-math -mtune=opteron -m32 FCFLAGS=-O3 -ffast-math
-mtune=opteron -m32 F77=gfortran LDFLAGS=-O3 -ffast-math -mtune=opteron
-m32 --prefix=/....../MPI/openmpi-1.5.1mt/linux32/gcc

With a newer version of GCC, version 4.2.4 (and also gcc version
4.5.1) the configuration completed fine.

Does there an error in my way of configuring, or is there a problem in
the configure itself? I think the non-ability to configure and build
OpenMPI with the default compiler on CentOS 5.5 is still a problem, also
other versions of GCC seem not to have the same issue.

Best wishes,

Paul

-- 
Dipl.-Inform. Paul Kapinos   -   High Performance Computing,
RWTH Aachen University, Center for Computing and Communication
Seffenter Weg 23,  D 52074  Aachen (Germany)
Tel: +49 241/80-24915