Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] cannot restrict port numbers using btl_tcp_port_min_v4 and btl_tcp_port_range_v4
From: Ralph Castain (rhc_at_[hidden])
Date: 2010-12-10 17:49:59


mpirun is not an MPI process, and so it doesn't obey the btl port params. To control mpirun's ports (and those used by the ORTE daemons), use the oob_tcp_port... params

On Dec 10, 2010, at 3:29 PM, Tang, Hsiu-Khuern wrote:

>
> Hi,
>
> I am trying to understand how to control the range of ports used by Open MPI.
> I tried setting the parameters btl_tcp_port_min_v4 and btl_tcp_port_range_v4,
> but they don't seem to have an effect.
>
> I am using Open MPI 1.4.2 from Debian sid, but get the same result on RHEL5.
>
> When I run a program like
>
> mpirun --host host1,host2 -np 2 --mca btl_tcp_port_min_v4 10000 --mca btl_tcp_port_range_v4 10 sleep 100
>
> and then in another terminal run "netstat -plnt", should I expect to see mpirun
> listening on one or more ports between 10000 and 10009? I don't -- mpirun is
> invariably listening on some other ports.
>
> Thanks!
>
> --
> Best,
> Hsiu-Khuern.
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users