Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] failure to launch MPMD program on win32 w 1.4.3
From: Ralph Castain (rhc_at_[hidden])
Date: 2010-11-30 09:36:25


It truly does help to know what version of OMPI you are using - otherwise, there is little we can do to help

On Nov 30, 2010, at 4:05 AM, Hicham Mouline wrote:

> Hello,
>
> I have successfully run
>
> mpirun -np 3 .\test.exe
>
> when I try MPMP
>
> mpirun -np 3 .\test.exe : -np 3 .\test2.exe
>
> where test and test2 are identical (just for a trial), I get this error:
>
> [hostname:04960] [[47427,1],0]-[[47427,0],0] mca_oob_tcp_peer_send_blocking: send() failed: Unknown error (10057)
> [hostname:04960] [[47427,1],0] routed:binomial: Connection to lifeline [[47427,0],0] lost
>
> Granted this uses boost::mpi, but it worked for SPMD, and the source for the main function is trivial:
>
> #include <iostream>
> #include <boost/mpi.hpp>
>
> namespace mpi = boost::mpi;
>
> int main(int argc, char* argv[])
> {
> mpi::environment env(argc, argv);
> mpi::communicator world;
>
> std::cout << "Process #" << world.rank() << " says "<< std::endl;
> return 0;
> }
>
>
> as far as I understand, there should be 1 world with 6 processes, ranking 0 1 2 , 3 4 5
>
> regards,
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users