Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] [Rocks-Discuss] compiling Openmpi on solaris studio express
From: Terry Dontje (terry.dontje_at_[hidden])
Date: 2010-11-30 06:31:49


Actually there is a way to modify the configure file that will not
require the autogen.sh to be ran.
If you go into configure and search for "Sun F" a few lines down will be
one of three assignments:
lt_prog_compiler_wl
lt_prog_compiler_wl_F77
lt_prog_compiler_wl_FC

If you change them all to '-Qoption ld' and then do the configure things
should work.

Good luck,

--td

On 11/30/2010 06:19 AM, Terry Dontje wrote:
> On 11/29/2010 05:41 PM, Nehemiah Dacres wrote:
>> thanks.
>> FYI: its openmpi-1.4.2 from a tarball like you assume
>> I changed this line
>> *Sun\ F* | *Sun*Fortran*)
>> # Sun Fortran 8.3 passes all unrecognized flags to the linker
>> _LT_TAGVAR(lt_prog_compiler_pic, $1)='-KPIC'
>> _LT_TAGVAR(lt_prog_compiler_static, $1)='-Bstatic'
>> _LT_TAGVAR(lt_prog_compiler_wl, $1)='-Qoption ld '
>>
>> unfortunately my autoconf tool is out of date (2.59 , it says it
>> wants 2.60+ )
>>
> The build page (http://www.open-mpi.org/svn/building.php) show's the
> versions of the tools you need to build OMPI. Sorry, unfortunately in
> order for this workaround to work you need to re-autogen.sh no way
> around that.
>>
>> On Mon, Nov 29, 2010 at 4:11 PM, Rolf vandeVaart
>> <rolf.vandevaart_at_[hidden] <mailto:rolf.vandevaart_at_[hidden]>> wrote:
>>
>> No, I do not believe so. First, I assume you are trying to build
>> either 1.4 or 1.5, not the trunk.
>> Secondly, I assume you are building from a tarfile that you have
>> downloaded. Assuming these
>> two things are true, then (as stated in the bug report), prior to
>> running configure, you want to
>> make the following edits to config/libtool.m4 in all the places
>> you see it. ( I think just one place)
>>
>> FROM:
>>
>> *Sun\ F*)
>> # Sun Fortran 8.3 passes all unrecognized flags to the linker
>> _LT_TAGVAR(lt_prog_compiler_pic, $1)='-KPIC'
>> _LT_TAGVAR(lt_prog_compiler_static, $1)='-Bstatic'
>> _LT_TAGVAR(lt_prog_compiler_wl, $1)=''
>> ;;
>>
>> TO:
>>
>> *Sun\ F*)
>> # Sun Fortran 8.3 passes all unrecognized flags to the linker
>> _LT_TAGVAR(lt_prog_compiler_pic, $1)='-KPIC'
>> _LT_TAGVAR(lt_prog_compiler_static, $1)='-Bstatic'
>> _LT_TAGVAR(lt_prog_compiler_wl, $1)='-Qoption ld '
>> ;;
>>
>>
>>
>> Note the difference in the lt_prog_compiler_wl line.
>>
>> I ran ./configure anyway, but I don't think it did anything
> It didn't, the change to libtool.m4 only affects the build system when
> you do an autogen.sh.
>
> --td
>>
>>
>> Then, you need to run ./autogen.sh. Then, redo your configure
>> but you do not need to do anything
>> with LDFLAGS. Just use your original flags. I think this should
>> work, but I am only reading
>> what is in the ticket.
>>
>> Rolf
>>
>>
>>
>> On 11/29/10 16:26, Nehemiah Dacres wrote:
>>> that looks about right. So the suggestion:
>>>
>>> ./configure LDFLAGS="-notpath ... ... ..."
>>>
>>> -notpath should be replaced by whatever the proper flag should be, in my case -L<path> ?
>>>
>>>
>>>
>>> On Mon, Nov 29, 2010 at 3:16 PM, Rolf vandeVaart
>>> <rolf.vandevaart_at_[hidden] <mailto:rolf.vandevaart_at_[hidden]>>
>>> wrote:
>>>
>>> This problem looks a lot like a thread from earlier today.
>>> Can you look at this
>>> ticket and see if it helps? It has a workaround documented
>>> in it.
>>>
>>> https://svn.open-mpi.org/trac/ompi/ticket/2632
>>>
>>> Rolf
>>>
>>>
>>> On 11/29/10 16:13, Prentice Bisbal wrote:
>>>> No, it looks like ld is being called with the option -path, and your
>>>> linker doesn't use that switch. Grep you Makefile(s) for the string
>>>> "-path". It's probably in a statement defining LDFLAGS somewhere.
>>>>
>>>> When you find it, replace it with the equivalent switch for your
>>>> compiler. You may be able to override it's value on the configure
>>>> command-line, which is usually easiest/best:
>>>>
>>>> ./configure LDFLAGS="-notpath ... ... ..."
>>>>
>>>> --
>>>> Prentice
>>>>
>>>>
>>>> Nehemiah Dacres wrote:
>>>>
>>>>> it may have been that I didn't set ld_library_path
>>>>>
>>>>> On Mon, Nov 29, 2010 at 2:36 PM, Nehemiah Dacres<dacresni_at_[hidden] <mailto:dacresni_at_[hidden]>
>>>>> <mailto:dacresni_at_[hidden]>> wrote:
>>>>>
>>>>> thank you, you have been doubly helpful, but I am having linking
>>>>> errors and I do not know what the solaris studio compiler's
>>>>> preferred linker is. The
>>>>>
>>>>> the configure statement was
>>>>>
>>>>> ./configure --prefix=/state/partition1/apps/sunmpi/
>>>>> --enable-mpi-threads --with-sge --enable-static
>>>>> --enable-sparse-groups CC=/opt/oracle/solstudio12.2/bin/suncc
>>>>> CXX=/opt/oracle/solstudio12.2/bin/sunCC
>>>>> F77=/opt/oracle/solstudio12.2/bin/sunf77
>>>>> FC=/opt/oracle/solstudio12.2/bin/sunf90
>>>>>
>>>>> compile statement was
>>>>>
>>>>> make all install 2>errors
>>>>>
>>>>>
>>>>> error below is
>>>>>
>>>>> f90: Warning: Option -path passed to ld, if ld is invoked, ignored
>>>>> otherwise
>>>>> f90: Warning: Option -path passed to ld, if ld is invoked, ignored
>>>>> otherwise
>>>>> f90: Warning: Option -path passed to ld, if ld is invoked, ignored
>>>>> otherwise
>>>>> f90: Warning: Option -path passed to ld, if ld is invoked, ignored
>>>>> otherwise
>>>>> f90: Warning: Option -soname passed to ld, if ld is invoked, ignored
>>>>> otherwise
>>>>> /usr/bin/ld: unrecognized option '-path'
>>>>> /usr/bin/ld: use the --help option for usage information
>>>>> make[4]: *** [libmpi_f90.la <http://libmpi_f90.la> <http://libmpi_f90.la>] Error 2
>>>>> make[3]: *** [all-recursive] Error 1
>>>>> make[2]: *** [all] Error 2
>>>>> make[1]: *** [all-recursive] Error 1
>>>>> make: *** [all-recursive] Error 1
>>>>>
>>>>> am I doing this wrong? are any of those configure flags unnecessary
>>>>> or inappropriate
>>>>>
>>>>>
>>>>>
>>>>> On Mon, Nov 29, 2010 at 2:06 PM, Gus Correa<gus_at_[hidden] <mailto:gus_at_[hidden]>
>>>>> <mailto:gus_at_[hidden]>> wrote:
>>>>>
>>>>> Nehemiah Dacres wrote:
>>>>>
>>>>> I want to compile openmpi to work with the solaris studio
>>>>> express or
>>>>> solaris studio. This is a different version than is installed on
>>>>> rockscluster 5.2 and would like to know if there any
>>>>> gotchas or configure
>>>>> flags I should use to get it working or portable to nodes on
>>>>> the cluster.
>>>>> Software-wise, it is a fairly homogeneous environment with
>>>>> only slight
>>>>> variations on the hardware side which could be isolated
>>>>> (machinefile flag
>>>>> and what-not)
>>>>> Please advise
>>>>>
>>>>>
>>>>> Hi Nehemiah
>>>>> I just answered your email to the OpenMPI list.
>>>>> I want to add that if you build OpenMPI with Torque support,
>>>>> the machine file for each is not needed, it is provided by Torque.
>>>>> I believe the same is true for SGE (but I don't use SGE).
>>>>> Gus Correa
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Nehemiah I. Dacres
>>>>> System Administrator
>>>>> Advanced Technology Group Saint Louis University
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Nehemiah I. Dacres
>>>>> System Administrator
>>>>> Advanced Technology Group Saint Louis University
>>>>>
>>>>>
>>>>> ------------------------------------------------------------------------
>>>>>
>>>>> _______________________________________________
>>>>> users mailing list
>>>>> users_at_[hidden] <mailto:users_at_[hidden]>
>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>>
>>>> _______________________________________________
>>>> users mailing list
>>>> users_at_[hidden] <mailto:users_at_[hidden]>
>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>
>>>
>>>
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden] <mailto:users_at_[hidden]>
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>
>>>
>>>
>>>
>>> --
>>> Nehemiah I. Dacres
>>> System Administrator
>>> Advanced Technology Group Saint Louis University
>>>
>>> ------------------------------------------------------------------------
>>> _______________________________________________ users mailing
>>> list users_at_[hidden] <mailto:users_at_[hidden]>
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden] <mailto:users_at_[hidden]>
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
>>
>>
>> --
>> Nehemiah I. Dacres
>> System Administrator
>> Advanced Technology Group Saint Louis University
>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> --
> Oracle
> Terry D. Dontje | Principal Software Engineer
> Developer Tools Engineering | +1.781.442.2631
> Oracle *- Performance Technologies*
> 95 Network Drive, Burlington, MA 01803
> Email terry.dontje_at_[hidden] <mailto:terry.dontje_at_[hidden]>
>
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Oracle
Terry D. Dontje | Principal Software Engineer
Developer Tools Engineering | +1.781.442.2631
Oracle *- Performance Technologies*
95 Network Drive, Burlington, MA 01803
Email terry.dontje_at_[hidden] <mailto:terry.dontje_at_[hidden]>



picture
picture