Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Unable to find the following executable
From: Tushar Andriyas (thugnomics28_at_[hidden])
Date: 2010-11-19 09:35:58


It just gives back the info on folders in my home directory. Dont get me
wrong but i m kinda new in this. So, could u type out d full command which i
need to give?

Tushar

On Thu, Nov 18, 2010 at 8:35 AM, Ralph Castain <rhc_at_[hidden]> wrote:

> You can qsub a simple "ls" on that path - that will tell you if the path is
> valid on all machines in that allocation.
>
> What typically happens is that home directories aren't remotely mounted, or
> are mounted on a different location.
>
>
> On Thu, Nov 18, 2010 at 8:31 AM, Tushar Andriyas <thugnomics28_at_[hidden]>wrote:
>
>> no its not in the same directory as SWMF. I guess the path is the same
>> since all the machines in a cluster are configured d same way. How do I know
>> if this is not the case?
>>
>>
>> On Thu, Nov 18, 2010 at 8:25 AM, Ralph Castain <rhc_at_[hidden]> wrote:
>>
>>> Is you "hello world" test program in the same directory as SWMF? Is it
>>> possible that the path you are specifying is not available on all of the
>>> remote machines? That's the most common problem we see.
>>>
>>>
>>> On Thu, Nov 18, 2010 at 7:59 AM, Tushar Andriyas <thugnomics28_at_[hidden]
>>> > wrote:
>>>
>>>> Hi there,
>>>>
>>>> Thanks for the expedite reply. The thing is that although the mpirun is
>>>> setup correctly (since a simple hello world works), when I run the main
>>>> SWMF.exe executable, the cluster machines somehow fail to find the
>>>> executable (SWMF.exe).
>>>>
>>>> So, I have attached the sample error file from one of the runs
>>>> (SWMF.e143438) and also the MAKEFILES so that you could better gauge the
>>>> problem. The makefiles have Linux as the OS and pgf90 as compiler with
>>>> mpif90 as the linker. I am using openmpi-1.2.7-pgi. Job is submitted using a
>>>> batch file (job.bats) and the scheduler is Torque (version I am not sure but
>>>> I can see three on the machines viz 2.0.0, 2.2.1, 2.5.2).
>>>>
>>>> I have also attached an error file from one of the clusters (WASATCH viz
>>>> SWMF.e143439) and UINTA (SWMF.e143440) with the *whole path of the exe
>>>> as Srirangam mentioned as follows (in the batch file)*.
>>>>
>>>> mpirun --prefix /opt/libraries/openmpi/openmpi-1.2.7-pgi
>>>> /home/A00945081/SWMF_v2.3/run/SWMF.exe > runlog_`date +%y%m%d%H%M`
>>>>
>>>> I have tried both mpirun and mpiexec but nothing seems to work.
>>>>
>>>> Tushar
>>>>
>>>>
>>>> On Wed, Nov 17, 2010 at 8:12 PM, Addepalli, Srirangam V <
>>>> srirangam.v.addepalli_at_[hidden]> wrote:
>>>>
>>>>> Hello Tushar,
>>>>> Have you tried supplying the full path of the executable just to check
>>>>> ?
>>>>> Rangam
>>>>> ________________________________________
>>>>> From: users-bounces_at_[hidden] [users-bounces_at_[hidden]] On
>>>>> Behalf Of Tushar Andriyas [thugnomics28_at_[hidden]]
>>>>> Sent: Wednesday, November 17, 2010 8:49 PM
>>>>> To: users_at_[hidden]
>>>>> Subject: [OMPI users] Unable to find the following executable
>>>>>
>>>>> Hi there,
>>>>>
>>>>> I am new to using mpi commands and was stuck in problem with running a
>>>>> code. When I submit my job through a batch file, the job exits with the
>>>>> message that the executable could not be found on the machines. I have tried
>>>>> a lot of options such as PBS -V and so on on but the problem persists. If
>>>>> someone is interested, I can send the full info on the cluster, the compiler
>>>>> and openmpi settings and other stuff. BTW the launcher is torque (which you
>>>>> might have guessed). The code does not have a forum so I am in a deep mire.
>>>>>
>>>>> Thanks,
>>>>> Tushar
>>>>>
>>>>> _______________________________________________
>>>>> users mailing list
>>>>> users_at_[hidden]
>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>>
>>>>
>>>>
>>>> _______________________________________________
>>>> users mailing list
>>>> users_at_[hidden]
>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>
>>>
>>>
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>
>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>