Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] link problem on 64bit platform
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2010-11-01 08:24:02

On Nov 1, 2010, at 5:20 AM, jody wrote:

> jody_at_aim-squid_0 ~/progs $ mpiCC -g -o HelloMPI HelloMPI.cpp
> /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.4/../../../../x86_64-pc-linux-gnu/bin/ld:
> skipping incompatible /opt/openmpi-1.4.2/lib/ when
> searching for -lmpi_cxx

This is the key message -- it found, but the linker deemed it incompatible, so it skipped it.

How did you configure / build Open MPI? Did the C++ bindings library somehow get built with incompatible flags as compared to the other OMPI libraries? E.g., did you supply CFLAGS but not CXXFLAGS to the configure script?

Jeff Squyres
For corporate legal information go to: