Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] mixed versions of openmpi ? (1.4.1 and 1.4.3)
From: guillaume ranquet (guillaume.ranquet_at_[hidden])
Date: 2010-10-29 12:12:03


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi list,
I'm sorry to bother you with a stupid question.

we intend to have for a short period of time, some nodes with 1.4.3 and
others with 1.4.1 (before upgrading everyone to 1.4.3).

I made various test and found both versions to be running together quite
well with a mixed set of nodes.

my tests were quite simple, I compiled and ran mpi hello_worlds with
both versions.
It wouldn't be serious for me to assume both versions fully compatible
after these tests -and I must admit I lack the time and technical
knowledge to run further testing.

has anyone any insight on what have changed that would break compatibility?
I guess nothing, since they are the same major.minor :)

regards,
Guillaume Ranquet.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.16 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJMyvJTAAoJEEzIl7PMEAliT4kH/RY4WXhEO5R8H3DNIWW7Y91z
6q4BrymLrBSl7rnnEgALBMiPGK9lQgqEtv9k3xCFbfOfWXIFreIHH8ZFDzt1BjQI
TZ58SwVE9CIMmESoJ1P52R+WCbKYur3U2eda//1cfnZ28ZYjnKN/xYlT/wv8hqg3
GsW+seMR8X+1nNFkH1UQHIBVO2cXaK24BtSe4cvDFaMaUbe0Qlmxg55BbCSYB4ED
VBbplp/ty0tojmZdJLqSsp7nZ84oCfvAfZf16fJTDHNYhUSvNz/fldnxWrm7WTUb
VzM94yJf0IHfNAB/YvpXECGFL9cPWeG/F6Bm+r6GSMRvd0MeLbp1HWJTbVYlCwo=
=NwEP
-----END PGP SIGNATURE-----