Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Running simple MPI program
From: Gustavo Correa (gus_at_[hidden])
Date: 2010-10-23 20:02:58


Hi Brandon

Yes, as others said and you figured, version is important,
and installing from source is not hard, probably will save you more headaches than
installing the packages (which normally vary with the Linux distro version).

Regarding the environment variables.
You need to set the PATH and the LD_LIBRARY_PATH to point to the newly
installed-from-source OpenMPI bin and lib directories on *ALL* your home directories
in ALL machines (assuming the home directory is not shared via NFS or similar,
which I guess they aren't, based on what you said before).

If you use csh/tcsh this means putting something like this in your .cshrc/.tcshrc file
(not a visible file, a "dot" file, you need "ls -a" to see it, if absent just create it):

setenv PATH /path/to/openmpi/bin:${PATH}
setenv LD_LIBRARY_PATH /path/to/openmpi/lib

If you use sh/bash the file is .bashrc or .profile and the style is like this:

export PATH=/path/to/openmpi/bin:${PATH}
export LD_LIBRARY_PATH /path/to/openmpi/lib

OpenMPI (I think, Jeff and others may correct me if I am wrong) ssh to each machine
and gets your environment variables that are local to each machine. You need a
mechanism (such as the above) to set the same environment across the machines,
and to enable the OpenMPI stuff everywhere.

I am not sure, but since you are using IP addresses, not host names,
your /etc/hosts file may be OK.
 
I hope it helps.

Gus Correa

On Oct 23, 2010, at 3:10 PM, Brandon Fulcher wrote:

> Hi, so yes I'm trying to install the source but after installing, it does not seem to be able to locate the libraries.
>
> mpirun gives the error
> libopen-rte.so.0: cannot open shared object file: No such file or directory
>
> Of course, I have seen this faq http://www.open-mpi.org/faq/?category=running#adding-ompi-to-path
>
> But this is more than a little beyond me. The libraries seem to be installed in usr/lib, (at least, that's where it locates the library in question.) but I can't seem to get this to work by modifying LD_LIBRARY_PATH, or using the --prefix switch. Obviously I am doing something very wrong, never having bothered with editing paths before. (This is why I use packages.)
>
> On Sat, Oct 23, 2010 at 1:47 PM, Ashley Pittman <ashley_at_[hidden]> wrote:
>
> On 23 Oct 2010, at 17:58, Brandon Fulcher wrote:
> > So I checked the OMPI package details on both machines, they each are running Open MPI 1.3. . . but then I noticed that the packages are different versions. Basically, the slave is running the previous Ubuntu release, and the master is running the current one. Both have the most recent packages for their release. . .but perhaps that is enough of a difference?
>
> You need to have exactly the same version of OpenMPI installed on both machines. Typically in a cluster all machines are identical in terms of software, if this isn't the case for your systems then the easiest way might be to compile open mpi from source (on the older of the two machines would be best) and to install it to a common directory on both machines.
>
> Ashley.
>
> --
>
> Ashley Pittman, Bath, UK.
>
> Padb - A parallel job inspection tool for cluster computing
> http://padb.pittman.org.uk
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users