Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] openmpi 1.5 build from rpm fails: --program-prefix now checked in configure
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2010-10-19 20:12:22


Thanks for the report. Someone reported pretty much the same issue to me off-list a few days ago for RHEL5.

It looks like RHEL5 / 6 ship with Autoconf 2.63, and have a /usr/lib/rpm/macros that defines %configure to include options such as --program-suffix. We bootstrapped Open MPI v1.5 with Autoconf 2.65, which does not understand the --program-suffix option.

I don't know why AC 2.65 dropped the --program-suffix option, but this seems to be where we are.

I've emailed a contact at Red Hat asking for advice on what to do here -- I can't imagine Open MPI is the only package in this situation.

On Oct 19, 2010, at 4:47 AM, livelfs wrote:

> Hi
> this is to report that building openmpi-1.5 from rpm fails on Linux
> SLES10sp3 x86_64,
> due to --program-prefix switch use now checked in configure script
> delivered with 1.5.
>
> rpm is version 4.4.2-43.36.1
>
> rpmbuild --rebuild SRPMS/openmpi-1.5.0.src.rpm --define
> 'configure_options CC="/softs/gcc/4.5.1/bin/gcc
> " CXX="/softs/gcc/4.5.1/bin/g++
> " F77="/softs/gcc/4.5.1/bin/gfortran
> " FC="/softs/gcc/4.5.1/bin/gfortran "
> --prefix=/opt/openmpi/1.5.0/gfortran-4.5.1-gcc-4.5.1-BLCR-PBS
> --enable-static --enable-shared
> --with-wrapper-ldflags="-Wl,-rpath
> -Wl,/opt/openmpi/1.5.0/gfortran-4.5.1-gcc-4.5.1-BLCR-PBS/lib64
> -Wl,-rpath -Wl,/softs/blcr/0.8/lib"
> --with-memory-manager=ptmalloc2
> --enable-orterun-prefix-by-default --with-openib
> --disable-ipv6 --with-ft=cr
> --enable-ft-thread --enable-mpi-threads
> --with-blcr=/softs/blcr/0.8
> --enable-mpirun-prefix-by-default
> --with-tm=/opt/pbs/default
> --with-wrapper-libs="-lpthread -lutil -lrt"' --define '_prefix
> /opt/openmpi/1.5.0/gfortran-4.5.1-gcc-4.5.1-BLCR-PBS' --define '_name
> openmpi_gfortran-4.5.1-gcc-4.5.1-BLCR-PBS' --define '_topdir /scratch'
> --define '_unpackaged_files_terminate_build 0' --define
> 'use_default_rpm_opt_flags 0'
>
> ends with:
> [...]
> configure: WARNING: *** This configure script does not support
> --program-prefix, --program-suffix or --program-transform-name. Users
> are recommended to instead use --prefix with a unique directory and make
> symbolic links as desired for renaming.
> configure: error: *** Cannot continue
>
>
> In the present environment (SLES10sp3 x86_64, rpm 4.4.2-43.36.1),
> rpmbuild --rebuild produces and execs a temporary shell script calling
> configure
> with an *empty* --program-prefix switch (--program-prefix=).
>
> It works with openmpi 1.4.3
> but configure script from openmpi 1.5 is more picky about using
> --program-prefix, --program-suffix or --program-transform-name:
>
> # diff /usr/src/packages/SOURCES/openmpi-1.5/configure
> /usr/src/packages/SOURCES/openmpi-1.4.3/configure | grep program-prefix
> < # Suggestion from Paul Hargrove to disable --program-prefix and
> < { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: *** This
> configure script does not support --program-prefix, --program-suffix or
> --program-transform-name. Users are recommended to instead use --prefix
> with a unique directory and make symbolic links as desired for
> renaming." >&5
> < $as_echo "$as_me: WARNING: *** This configure script does not support
> --program-prefix, --program-suffix or --program-transform-name. Users
> are recommended to instead use --prefix with a unique directory and make
> symbolic links as desired for renaming." >&2;}
>
> If I remove the new control on --program-prefix in openmpi-1.5 configure
> script, the 1.5 build becomes OK.
>
> Regards,
> Stephane Rouberol
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/