Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] compilation error using pgf90 ver 9.0
From: Gus Correa (gus_at_[hidden])
Date: 2010-09-01 11:47:29


Hi Mohamed, Reuti, list

That issue with the pthread flag and PGI has been there for a while.
Actually, if I remember right, it is a glitch in libtool
(probably version dependent), not in OpenMPI.

The simplest workaround, pointed out by Orion Poplawski
here some time ago, is to configure OpenMPI
with the PGI switch -noswitcherror.
Worth giving it a try.

My $0.02
Gus Correa
---------------------------------------------------------------------
Gustavo Correa
Lamont-Doherty Earth Observatory - Columbia University
Palisades, NY, 10964-8000 - USA
---------------------------------------------------------------------

Reuti wrote:
> Hi,
>
> Am 01.09.2010 um 00:40 schrieb mohamed makhyoun:
>
>> Dear opem-mpi users:
>>
>> I have got the following error while compiling openmpi using pgf90 ver 9 and CC=gcc
>>
>> How I can run make and avoiding the -pthread flag ?.
>>
>> pgf90-Error-Unknown switch: -pthread
>> make[4]: *** [libmpi_f90.la] Error 1
>> make[4]: Leaving directory `/home/mohamed/bin/openmpi-1.4.1/build/ompi/mpi/f90'
>> make[3]: *** [all-recursive] Error 1
>> make[3]: Leaving directory `/home/mohamed/bin/openmpi-1.4.1/build/ompi/mpi/f90'
>> make[2]: *** [all] Error 2
>> make[2]: Leaving directory `/home/mohamed/bin/openmpi-1.4.1/build/ompi/mpi/f90'
>> make[1]: *** [all-recursive] Error 1
>> make[1]: Leaving directory `/home/mohamed/bin/openmpi-1.4.1/build/ompi'
>> make: *** [all-recursive] Error
>
> you don't have the workstation package with pgcc/pgCC too (then it succeeds for me)?
>
> Although I think it's a bug, I tend to stay inside one and the same compile process with only one compiler vendor anyway.
>
> -- Reuti
>
> NB: Latest version is 1.4.2.
>
>
>> I appreciate if any one can help me.
>>
>> Best Regard
>>
>> M. Makhyoun
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users