Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Fwd: Problems with OpenMPI
From: Osvaldo Reis (osvaldoreisss_at_[hidden])
Date: 2010-08-31 12:32:42


Hi, I wanted to use openmpi, I install with no errors, and when I run de
examples in local it work well, but when I specify another host to run it
doesn't work. There are no errors but the it doesn't show anything and don't
start the process in another host and don't stop to run in localhost. Then I
press Crtl+C to killl the process and it shows:

^Cmpirun: killing job...

--------------------------------------------------------------------------
mpirun noticed that the job aborted, but has no info as to the process
that caused that situation.
--------------------------------------------------------------------------
--------------------------------------------------------------------------
mpirun was unable to cleanly terminate the daemons on the nodes shown
below. Additional manual cleanup may be required - please refer to
the "orte-clean" tool for assistance.
--------------------------------------------------------------------------
        anotherhost - daemon did not report back when launched

I loot at /var/log/secure and it started the connection but after he close
without execute anything.

Running localhost

[user_at_host1 examples]$ mpirun -np 8 --host localhost ./hello_c
Hello, world, I am 0 of 8
Hello, world, I am 1 of 8
Hello, world, I am 2 of 8
Hello, world, I am 4 of 8
Hello, world, I am 5 of 8
Hello, world, I am 6 of 8
Hello, world, I am 7 of 8
Hello, world, I am 3 of 8

Running in another host

[user_at_host1 examples]$ mpirun -np 8 --host anotherhost ./hello_c

Some help please!

-- 
Osvaldo Reis Junior
Engenharia de Computação - UEPG
Laboratório de Genômica e Expressão - LGE
Universidade Estadual de Campinas - UNICAMP
MSN: osvaldoreis85_at_[hidden]
Skype: osvaldoreisss
Cel: (19) 8128-5273