Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] problem with .bashrc stetting of openmpi
From: Gus Correa (gus_at_[hidden])
Date: 2010-08-13 10:47:47


Hi Sunita

My guess is that you are picking a wrong mpiexec,
because of the way you set your PATH.
What do you get from "which mpiexec"?

Try *pre-pending" the OpenMPI path to the existing PATH,
instead of appending it (that's what you did with the LD_LIBRARY_PATH):

export PATH=/home/sunitap/soft/openmpi/bin:$PATH

My $0.02
Gus Correa
---------------------------------------------------------------------
Gustavo Correa
Lamont-Doherty Earth Observatory - Columbia University
Palisades, NY, 10964-8000 - USA
---------------------------------------------------------------------

sunita_at_[hidden] wrote:
> Dear Open-mpi users,
>
> I installed openmpi-1.4.1 in my user area and then set the path for
> openmpi in the .bashrc file as follow. However, am still getting following
> error message whenever am starting the parallel molecular dynamics
> simulation using GROMACS. So every time am starting the MD job, I need to
> source the .bashrc file again.
>
> Earlier in some other machine I did the same thing and was not getting any
> problem.
>
> Could you guys suggest what would be the problem?
>
> ============.bashrc============
> #path for openmpi
> export PATH=$PATH:/home/sunitap/soft/openmpi/bin
> export CFLAGS="-I/home/sunitap/soft/openmpi/include"
> export LDFLAGS="-L/home/sunitap/soft/openmpi/lib"
> export LD_LIBRARY_PATH=/home/sunitap/soft/openmpi/lib:$LD_LIBRARY_PATH
>
> ============== error message ==============
> mdrun_mpi: error while loading shared libraries: libmpi.so.0: cannot open
> shared object file: No such file or directory
>
> ============================================
>
> Thanks for any help.
> Best regards,
> Sunita
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users