Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] openMPI shared with NFS, but says different version
From: Cristobal Navarro (axischire_at_[hidden])
Date: 2010-07-27 19:07:40


Thanks Gus,

but i already had the paths

fcluster_at_agua:~$ echo $PATH
/opt/openmpi-1.4.2/bin:/opt/cfc/sge/bin/lx24-amd64:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
fcluster_at_agua:~$ echo $LD_LIBRARY_PATH
/opt/openmpi-1.4.2/lib:
fcluster_at_agua:~$

even weird, errors come sometimes from the master node (agua)

On Tue, Jul 27, 2010 at 6:59 PM, Gus Correa <gus_at_[hidden]> wrote:

> Hi Cristobal
>
> Try using the --prefix option of mpiexec.
> "man mpiexec" is your friend!
>
> Alternatively, append the OpenMPI directories to your
> PATH *and* LD_LIBRARY_PATH on your .bashrc/.csrhc file
> See this FAQ:
> http://www.open-mpi.org/faq/?category=running#adding-ompi-to-path
>
> I hope it helps,
> Gus Correa
>
> Cristobal Navarro wrote:
>
>> Hi,
>> Even when executing a hello world openmpi, i get this error, which is then
>> ignored.
>> fcluster_at_fuego:~$ mpirun --hostfile myhostfile -np 5 testMPI/hola
>> [agua:02357] mca: base: component_find: unable to open
>> /opt/openmpi-1.4.2/lib/openmpi/mca_btl_ofud: perhaps a missing symbol, or
>> compiled for a different version of Open MPI? (ignored)
>> [agua:02354] mca: base: component_find: unable to open
>> /opt/openmpi-1.4.2/lib/openmpi/mca_btl_ofud: perhaps a missing symbol, or
>> compiled for a different version of Open MPI? (ignored)
>> [agua:02356] mca: base: component_find: unable to open
>> /opt/openmpi-1.4.2/lib/openmpi/mca_btl_ofud: perhaps a missing symbol, or
>> compiled for a different version of Open MPI? (ignored)
>> [agua:02358] mca: base: component_find: unable to open
>> /opt/openmpi-1.4.2/lib/openmpi/mca_btl_ofud: perhaps a missing symbol, or
>> compiled for a different version of Open MPI? (ignored)
>> [agua:02355] mca: base: component_find: unable to open
>> /opt/openmpi-1.4.2/lib/openmpi/mca_btl_ofud: perhaps a missing symbol, or
>> compiled for a different version of Open MPI? (ignored)
>> [agua:02358] mca: base: component_find: unable to open
>> /opt/openmpi-1.4.2/lib/openmpi/mca_btl_openib: perhaps a missing symbol, or
>> compiled for a different version of Open MPI? (ignored)
>> [agua:02355] mca: base: component_find: unable to open
>> /opt/openmpi-1.4.2/lib/openmpi/mca_btl_openib: perhaps a missing symbol, or
>> compiled for a different version of Open MPI? (ignored)
>> [agua:02354] mca: base: component_find: unable to open
>> /opt/openmpi-1.4.2/lib/openmpi/mca_btl_openib: perhaps a missing symbol, or
>> compiled for a different version of Open MPI? (ignored)
>> [agua:02356] mca: base: component_find: unable to open
>> /opt/openmpi-1.4.2/lib/openmpi/mca_btl_openib: perhaps a missing symbol, or
>> compiled for a different version of Open MPI? (ignored)
>> [agua:02357] mca: base: component_find: unable to open
>> /opt/openmpi-1.4.2/lib/openmpi/mca_btl_openib: perhaps a missing symbol, or
>> compiled for a different version of Open MPI? (ignored)
>> Process 3 on agua out of 5
>> Process 4 on agua out of 5
>> Process 1 on agua out of 5
>> Process 2 on agua out of 5
>> Process 0 on agua out of 5
>>
>>
>> /opt/openmpi-1.4.2/ is shared through NFS.
>>
>> master node did had an older openmpi version before installing 1.4.2, but
>> i removed them all with
>> sudo apt-get --purge remove libopenmpi1 libopenmpi-dev openmpi-bin
>> openmpi-dev openmpi-common
>> i checked for /usr/lib64/openmpi and for /usr/lib/openmpi and deleted
>> them.
>>
>> however, when compiling again i keep getting this error,
>> something must be remaining from the older version of openmpi, but i
>> really dont know where that remaining could be.
>> any help, welcome
>>
>>
>> ------------------------------------------------------------------------
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>