Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] How to launch mpirun 1.4.2 with --no-daemonize argument in order to run pvserver, is there an equivalent flag??
From: Ralph Castain (rhc_at_[hidden])
Date: 2010-07-21 18:24:57


Sorry - the cmd line option you are looking for was changed to avoid confusion. It is now --leave-session-attached

HTH
Ralph

On Jul 21, 2010, at 4:15 PM, Juan Francisco Alvarez Urquijo wrote:

> Hi all:
>
> I'm using openmpi-1.4.2. I need to run pvserver(a mpi program of paraview) in a cluster. I have Mac OS X 10.6.4 in all my hosts and in the server. I had configure ssh
>
> with no password.
>
> I try tu run pvserver (The paraview server) in a cluster, using the next comand:
>
> $ mpirun --hostfile myHostFile -np 12 pvserver -tdx=4 -tdy=3
> Listen on port: 11111
>
> Waiting for client...
>
> Then in my client i run paraview an I connect to the server
> $ paraview
> Waiting for server...
>
>
> The server tries to open the viewport in the other computers but here is the error
>
>
> $mpirun --hostfile myHostFile -np 12 pvserver -tdx=4 -tdy=3
> Listen on port: 11111
> Waiting for client...
> Client connected.
> Tue Jul 20 15:42:16 macMini1.local pvserver[10059] <Error>:
>
> kCGErrorRangeCheck: On-demand launch of the Window Server is allowed for root user only.
> Tue Jul 20 15:42:16 macMini1.local pvserver[10059] <Error>: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.
>
>
> .....
>
>
>
> I read about that error. I found this thread http://www.mail-archive.com/paraview@paraview.org/msg06964.html
>
>
> Here Takuya OSHIMA wrote that we need to run openmpi like this:
>
> $ mpirun --no-daemonize --hostfile myHostFile -np 12 pvserver -tdx=4 -tdy=3
>
>
> But this flag --no-daemonize is not part of mpirun yet, i guess it's not implemented in version 1.4.2.
>
>
> My questions are:
>
> Is there an equivalent flag in openmpi-1.4.2 for --no-daemonize??
> If not, How could I run mpirun in order not to run in background??
> Does anyone has tried this??
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users