Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Install OpenMPI on Win 7 machine
From: Alexandru Blidaru (alexsb92_at_[hidden])
Date: 2010-07-13 11:14:08


It works perfectly! Thanks a lot guys. You've been really helpful especially
you Damien Hocking and Shiqing Fan. All this complicated process makes me
wonder how complicated the code behind OpenMPI and MPI in general is. In
some cases, mailing lists really are a lot more useful than online forums.

Again, thank you very much for your help.

Cheers,
Alex

On Mon, Jul 12, 2010 at 8:00 PM, Damien Hocking <damien_at_[hidden]> wrote:

> Cool. If you're building OpenMPI on 32-bit Windows as well, you won't
> have any 64-bit switches to sort out. This part of my instructions:
>
> Visual Studio command prompt: "Start, All Programs, Visual Studio 2008,
> Visual Studio Tools, Visual Studio 2008 Win64 x64 Command Prompt" is
> slightly wrong for 32-bit Windows, there won't be a Win64 x64 prompt. There
> will be only one command prompt option on a 32-bit install (use that), and
> CMake will have set you up with a 32-bit build by default, so you'll be
> fine. Post back if you need help.
>
> Damien
>
>
> On 12/07/2010 5:47 PM, Alexandru Blidaru wrote:
>
> I am running 32 bit Windows. The actual cluster is 64 bit and the OS is
> CentOS
>
> On Mon, Jul 12, 2010 at 7:15 PM, Damien Hocking <damien_at_[hidden]> wrote:
>
>> You don't need to check anything alse in the red window, OpenMPI doesn't
>> know it's in a virtual machine. If you're running Windows in a virtual
>> cluster, are you running as 32-bit or 64-bit?
>>
>> Damien
>>
>>
>> On 12/07/2010 5:05 PM, Alexandru Blidaru wrote:
>>
>> Wow thanks a lot guys. I'll try it tomorrow morning. I'll admit that this
>> time when i saw that there are some header files "not found" i didn't even
>> bother going through the all process as I did previously. Could have had it
>> installed by today. Well i'll give it a try tomorrow and come back to you
>> with a confirmation of whether it works or not. For the "virtual cluster",
>> should I select check any of the checkboxes in the red window?
>>
>> Either way, thanks a lot guys, you've been of great help to me. I really
>> want to do my project well, as not many almost-18 year olds get to work with
>> clusters and I'd like to take full advantage of the experience
>>
>>
>> On Mon, Jul 12, 2010 at 5:38 PM, Damien <damien_at_[hidden]> wrote:
>>
>>> Alex,
>>>
>>> That red window is what you should see after the first Configure step in
>>> CMake. You need to do the next few steps in CMake and Visual Studio to get
>>> a Windows OpenMPI build done. That's how CMake works. It's complicated
>>> because CMake has to be able to build on multiple OSes so what you do on
>>> each OS is different. Here's what to do:
>>>
>>> As part of your original CMake setup, it will have asked you where to put
>>> the CMake binaries. That's in "Where to build the binaries" line in the
>>> main CMake window, at the top. Note that these binaries aren't the OpenMPI
>>> binaries, they're the Visual Studio project files that Visual Studio uses to
>>> build the OpenMPI binaries.
>>>
>>> See the CMAKE_BUILD_TYPE line? It says Debug. Change Debug to Release
>>> if you want a Release build (you probably do). Press the Configure button
>>> again and let it run. That should be all clean. Now press the Generate
>>> button. That will build the Visual Studio project files for you. They'll
>>> go to the "Where to build the binaries" directory. From here you're done
>>> with CMake.
>>>
>>> Next you have two options. You can build from a command line, or from
>>> within Visual Studio itself. For command-line instructions, read this:
>>>
>>> https://www.open-mpi.org/community/lists/users/2010/02/12013.php
>>>
>>> Note that you need to execute the devenv commands in that post from
>>> within a Visual Studio command prompt: Start, All Programs, Visual Studio
>>> 2008, Visual Studio Tools, Visual Studio 2008 Win64 x64 Command Prompt. I'm
>>> assuming you want a 64-bit build. You need to be in that "Where to build
>>> the binaries" directory as well.
>>>
>>> To use Visual Studio directly, start Visual Studio, and open the
>>> OpenMPI.sln project file that's in your "Where to build the binaries"
>>> directory. In the Solution Explorer you'll see a list of sub-projects.
>>> Right-click the top heading: Solution 'Open MPI' and select Configuration
>>> Manager. You should get a window that says at the top Active Solution
>>> Configuration, with Release below it. If it says Debug, just change that to
>>> Release and it will flip all the sub-projects over as well. Note on the the
>>> list of projects the INSTALL project will not be checked. Check that now
>>> and close the window. Now right-click Solution 'Open MPI' again and hit
>>> Build Solution. It takes a while to compile everything. If you get errors
>>> about error code -31 and mt.exe at the end of the build, that's your virus
>>> scanner locking the new exe/dll files and the install project complains.
>>> Keep right-clicking and Build Solution until it goes through. The final
>>> Open MPI include files and binaries are in the
>>> C:\Users\Alex's\Downloads......\installed directory.
>>>
>>> HTH
>>>
>>> Damien
>>>
>>> PS OpenMPI 1.4.2 doesn't have Fortran support on Windows. You need the
>>> dev 1.5 series for that and a Fortran compiler.
>>>
>>>
>>> On 12/07/2010 11:35 AM, Alexandru Blidaru wrote:
>>>
>>>> Hey,
>>>>
>>>> I installed a 90 day trial of Visual Studio 2008, and I am pretty sure I
>>>> am getting the exact same thing. The log and the picture are attached just
>>>> as last time. Any new ideas?
>>>>
>>>> Regards,
>>>> Alex
>>>>
>>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>
>>
>>
>> _______________________________________________
>> users mailing listusers_at_[hidden]http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>
>
> _______________________________________________
> users mailing listusers_at_[hidden]http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>