Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Install OpenMPI on Win 7 machine
From: Alexandru Blidaru (alexsb92_at_[hidden])
Date: 2010-07-12 13:35:29


Hey,

I installed a 90 day trial of Visual Studio 2008, and I am pretty sure I am
getting the exact same thing. The log and the picture are attached just as
last time. Any new ideas?

Regards,
Alex

On Mon, Jul 12, 2010 at 9:58 AM, Shiqing Fan <fan_at_[hidden]> wrote:

>
> Hi Alex,
>
> When the attachment is large, you can set the email directly to me off the
> list.
>
> For the problem you got, the reason is that you are using MinGW, but not
> Microsoft C/C++ compiler. Is that possible for you to just switch to
> Microsoft Visual Studio 2005 or 2008? There are still many problems for
> supporting MinGW at moment.
>
>
> Regards,
> Shiqing
>
>
> On 2010-7-12 3:48 PM, Alexandru Blidaru wrote:
>
> Hi,
>
> I am attaching all the output text resulted when configuring for the
> first time. I am also attaching a picture of the of the main area. My main
> purpose of installing OpenMPI is to set up a set of "virtual cluster" on the
> Windows 7 machine, so I could get accustomed with the different settings,
> and so I could try some small programs, before being allowed to work on the
> actual cluster.
>
> Note, this is the first time I am using a mailing list, so if I am not
> allowed attachments, please tell me. I tried to keep them as small as
> possible.
>
> Thanks for your help,
> Alex
>
> On Sat, Jul 10, 2010 at 7:16 AM, Shiqing Fan <fan_at_[hidden]> wrote:
>
>> Hi Alex,
>>
>> Building Open MPI using CMake is the recommended procedure, you probably
>> should stick with it, and it has been proved working well on different
>> Windows platforms. The other building procedures are not well supported for
>> some time now, and they are deprecated.
>>
>> For the problems that you got when building with CMake, it might because
>> some dependent headers/libraries are not installed. Could you please provide
>> the detail CMake error output, so that I can help you fix it?
>>
>>
>> Regards,
>> Shiqing
>>
>>
>>
>> On 2010-7-9 8:19 PM, Alexandru Blidaru wrote:
>>
>> Hey guys,
>>
>> This is my first time posting on an email list, so if I don't follow
>> certain protocols just tell me. Anyway, I am working at a research lab as a
>> High School Summer Intern, and part of my project involves installing
>> OpenMPI on a Windows machine to run some applications in virtual clusters. I
>> tried following the first two methods from the Windows ReadMe file, but none
>> of them work. For the first one, there are a bunch of header files cMake
>> can't find. For the second one, the cannot find the ompi-static.tgz tarball.
>> The set of files that I downloaded from OpenMPI can be found here (tried
>> both tars): http://www.open-mpi.org/software/ompi/v1.4/ .
>>
>> I noticed however that the ompi-static tarball can be found in the
>> Subversion that i obtained this way:
>> http://www.open-mpi.org/svn/mercurial.php . Can anyone tell me what I
>> might be doing wrong? Or maybe more detailed steps? it's the first time I
>> work with OpenMPI or any similar technologies.
>>
>> Thanks for your help,
>> Alex Blidaru
>>
>>
>> _______________________________________________
>> users mailing listusers_at_[hidden]http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
>>
>> --
>> --------------------------------------------------------------
>> Shiqing Fan http://www.hlrs.de/people/fan
>> High Performance Computing Tel.: +49 711 685 87234
>> Center Stuttgart (HLRS) Fax.: +49 711 685 65832
>> Address:Allmandring 30 email: fan_at_[hidden]
>> 70569 Stuttgart
>>
>>
>
>
> --
> --------------------------------------------------------------
> Shiqing Fan http://www.hlrs.de/people/fan
> High Performance Computing Tel.: +49 711 685 87234
> Center Stuttgart (HLRS) Fax.: +49 711 685 65832
> Address:Allmandring 30 email: fan_at_[hidden]
> 70569 Stuttgart
>
>





Capture_2.PNG