Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] ompi-ps failure on WinXP
From: Shiqing Fan (fan_at_[hidden])
Date: 2010-06-21 17:26:50


Hi Stephan,

I haven't tried to generate NMake Makefile to build Open MPI on Window,
the original purpose of using CMake was to generate Visual Studio
solution files. But if you can provide more information, e.g. error
messages, maybe I can figure out the problem for NMake.

Thanks,
Shiqing

On 2010-6-21 7:43 PM, Stephan Hackstedt wrote:
> Update: NMake Makefile creation works with VC8, but using nmake to
> install openmpi creates an error...
> i will try to find a way to build it.
>
> Stephan
>
> Stephan
>
> 2010/6/21 Stephan Hackstedt <stephan.hackstedt_at_[hidden]
> <mailto:stephan.hackstedt_at_[hidden]>>
>
> Hi Shiqing,
>
> i just checked out the code, but i am unable to create the nmake
> makefile with cmake.
> cmake tells me, it is unable to define 8-bit types.
> i also noticed, that for windows, the 1.4.2 release works with
> cmake, version above this making cmake to fail.
> i am using the VC10 compiler, but as an alternative i can use VC8.
> maybe it's worth a try.
> if i can make it, i will report :)
>
> Stephan
>
> 2010/6/21 Shiqing Fan <fan_at_[hidden] <mailto:fan_at_[hidden]>>
>
>
> Hi Stephan,
>
> For ompi-server test, you could probably refer to this Open
> MPI doc: http://www.open-mpi.org/doc/v1.4/man1/ompi-server.1.php .
>
> Possible tests would be "ompi-server -r -", "ompi-server -r
> +", "ompi-server -r file", or you can also write a MPI program
> using MPI_Lookup_name/MPI_Publish_name functions.
>
>
> Regards,
> Shiqing
>
>
>
>
>
> On 2010-6-20 11:14 AM, Stephan Hackstedt wrote:
>> Hello,
>>
>> i found no solution for this until yet.
>> Is there anyone who has a running ompi-server.exe on Windows XP?
>> If so, it would be great to tell me what i can do, to make
>> ompi-server-exe running properly on WinXP.
>>
>> Stephan
>>
>>
>> 2010/6/16 Stephan Hackstedt <stephan.hackstedt_at_[hidden]
>> <mailto:stephan.hackstedt_at_[hidden]>>
>>
>> Hello,
>>
>> i am using Open-MPI on a WinXP Professional VirtualBox
>> machine.
>> Open-MPI is build with cmake and nmake.
>> When i'm trying to use the ompi-ps tool i got the
>> following failure (the same with ompi-server, ompi-clean
>> and orted):
>>
>>
>>
>> #######################################################################
>>
>> D:\project\cluster_ompi>ompi-ps.exe
>> [vbox:03552] [[INVALID],INVALID] ORTE_ERROR_LOG: Not
>> found in file D:\project\op
>> enmpi_1_4_2_src\orte\runtime\orte_init.c at line 125
>> --------------------------------------------------------------------------
>> It looks like orte_init failed for some reason; your
>> parallel process is
>> likely to abort. There are many reasons that a parallel
>> process can
>> fail during orte_init; some of which are due to
>> configuration or
>> environment problems. This failure appears to be an
>> internal failure;
>> here's some additional information (which may only be
>> relevant to an
>> Open MPI developer):
>>
>> orte_ess_base_select failed
>> --> Returned value Not found (-13) instead of ORTE_SUCCESS
>> --------------------------------------------------------------------------
>>
>> ########################################################################
>>
>>
>>
>> on the other way, when use mpirun to start the tools like
>> "mpirun ompi-ps.exe" there is no error.
>> It this normal, or maybe is there an fix to solve my problem?
>> I'm would be nice if somebody has a solution for this.
>>
>>
>> Stephan
>>
>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden] <mailto:users_at_[hidden]>
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> --
> --------------------------------------------------------------
> Shiqing Fanhttp://www.hlrs.de/people/fan
> High Performance Computing Tel.: +49 711 685 87234
> Center Stuttgart (HLRS) Fax.: +49 711 685 65832
> Address:Allmandring 30 email:fan_at_[hidden] <mailto:fan_at_[hidden]>
> 70569 Stuttgart
>
>
>
>

-- 
--------------------------------------------------------------
Shiqing Fan                          http://www.hlrs.de/people/fan
High Performance Computing           Tel.: +49 711 685 87234
   Center Stuttgart (HLRS)            Fax.: +49 711 685 65832
Address:Allmandring 30               email: fan_at_[hidden]
70569 Stuttgart