Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] PGI problems
From: Prentice Bisbal (prentice_at_[hidden])
Date: 2010-05-10 13:08:22


Dave Love wrote:
> NEWS says that problems with PGI 10 were fixed in 1.4.1, but PGI 10
> won't configure 1.4.2 for me:
>
> configure: WARNING: Your compiler does not support offsetof macro
> configure: error: Configure: Cannot continue
> # pgcc -V
>
> pgcc 10.1-0 64-bit target on x86-64 Linux -tp k8-64e
> Copyright 1989-2000, The Portland Group, Inc. All Rights Reserved.
> Copyright 2000-2010, STMicroelectronics, Inc. All Rights Reserved.
>
> Actually I get the same result using PGI 8, so I guess this is something
> different from Ticket #2129.
>
> Does anyone have a fix, workaround, or diagnosis before I try to find
> one and make a bug report?

Dave,

I compiled 1.4.1 with PGI 9.0-3 a couple of months ago, and I just
compiled 1.4.2 with PGI 10.4:

$ pgcc -V

pgcc 10.4-0 64-bit target on x86-64 Linux -tp shanghai-64
Copyright 1989-2000, The Portland Group, Inc. All Rights Reserved.
Copyright 2000-2010, STMicroelectronics, Inc. All Rights Reserved.

Here's the configure command I used for the 1.4.2/10.4 build:

./configure CC=pgcc CXX=pgCC F77=pgf77 FC=pgf90 LDFLAGS="-L/usr/lib64"
--prefix=/usr/local/openmpi-1.4.2/pgi-10.4/x86_64 --disable-ipv6
--with-sge --with-openib --enable-static --with-libnuma=/usr | tee
configure.log 2>&1

Since I was successful compiled 1.4.1 with PGI 9 and 1.4.2 with PGI
10.4, I suspect the problem is local to you. Can you go through your
environment and make sure you don't have any settings that are incorrect
for this build that the configure script is picking up, like an
incorrect CPPFLAGS, LDFLAGS, or something like that?

I didn't see your exact configure command. If you're not already doing
so, I'd make sure you explicitly list the CC, CXX, FC and F77 variables,
including the full path to them if necessary to remove ambiguity about
what compiler you're really using.

-- 
Prentice Bisbal
Linux Software Support Specialist/System Administrator
School of Natural Sciences
Institute for Advanced Study
Princeton, NJ