Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] How do I run OpenMPI safely on a Nehalem standalone machine?
From: Eugene Loh (eugene.loh_at_[hidden])
Date: 2010-05-06 13:11:51


Gus Correa wrote:

> Hi Eugene
>
> Thank you for answering one of my original questions.
>
> However, there seems to be a problem with the syntax.
> Is it really "-mca btl btl_sm_num_fifos=some_number"?

No. Try "--mca btl_sm_num_fifos 4". Or,

% setenv OMPI_MCA_btl_sm_num_fifos 4
% ompi_info -a | grep btl_sm_num_fifos # check that things were set
correctly
% mpirun -n 4 a.out

> When I grep any component starting with btl_sm I get nothing:
>
> ompi_info --all | grep btl_sm
> (No output)

I'm no guru, but I think the reason has something to do with dynamically
loaded somethings. E.g.,

% /home/eugene/ompi/bin/ompi_info --all | grep btl_sm_num_fifos
(no output)
% setenv OPAL_PREFIX /home/eugene/ompi
% set path = ( $OPAL_PREFIX/bin $path )
% ompi_info --all | grep btl_sm_num_fifos
                 MCA btl: parameter "btl_sm_num_fifos" (current value:
"1", data source: default value)