Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] How do I run OpenMPI safely on a Nehalem standalone machine?
From: Gus Correa (gus_at_[hidden])
Date: 2010-05-06 11:26:57


Hi Ralph, Douglas

Ralph:

Yes, I am in black list of your ticket (gcc 4.4.3):

gcc --version
gcc (GCC) 4.4.3 20100127 (Red Hat 4.4.3-4)
Copyright (C) 2010 Free Software Foundation, Inc.

Is is possible (and not too time consuming) to install an
older gcc on this Fedora 12 box, and compile Open MPI with it?
(It may be easier just to install another Linux distribution,
I would guess. Fedora was not my choice, it is just a PITA.)

Douglas:

Thank you so much for telling your Linux distro, version, etc.
Now it is really starting to look as a distro/kernel/gcc issue.
I would not use Fedora, but I don't administer the box.

Would you know which gcc you used to build your Open MPI?
Or did you use Intel icc instead?

Cheers,
Gus
---------------------------------------------------------------------
Gustavo Correa
Lamont-Doherty Earth Observatory - Columbia University
Palisades, NY, 10964-8000 - USA
---------------------------------------------------------------------

Ralph Castain wrote:
> Yo Gus
>
> Just saw a ticket go by reminding us about
> continuing hang problems on shared memory when building with
> gcc 4.4.x - any chance you are in that category?
> You might have said something earlier in this thread....
>
> On May 5, 2010, at 5:54 PM, Douglas Guptill wrote:
>
>> On Wed, May 05, 2010 at 06:08:57PM -0400, Gus Correa wrote:
>>
>>> If anybody else has Open MPI working with hyperthreading and "sm"
>>> on a Nehalem box, I would appreciate any information about the
>>> Linux distro and kernel version being used.
>> Debian 5 (lenny), Core i7 920, Asus P6T MoBo, 12GB RAM, OpenMPI 1.2.8
>> (with a custom-built MPI_recv.c and MPI_Send.c, which cut down on the
>> cpu load caused by the busy wait polling). We have six (6) of these
>> machines. All configured the same.
>>
>> uname -a yields:
>> Linux screm 2.6.26-2-amd64 #1 SMP Thu Feb 11 00:59:32 UTC 2010 x86_64 GNU/Linux
>>
>> HyperThreading is on.
>>
>> Applications are -np 2 only:
>> mpirun --host localhost,localhost --byslot --mca btl sm,self -np 2 ${BIN}
>>
>> We normally run (up to) 4 of these jobs on each machine.
>>
>> Using Intel 11.0.074 and 11.1.0** compilers; have trouble with the
>> 11.1.0** and "-mcmodel=large -shared-intel" builds. Trouble meaning
>> the numerical results vary strangely. Still working on that problem.
>>
>> Hope that helps,
>> Douglas.
>>
>> P.S. Yes, I know OpenMPI 1.2.8 is old. We have been using it for 2
>> years with no apparent problems. When I saw comments like "machine
>> hung" for 1.4.1, and "data loss" for 1.3.x, I put aside thoughts of
>> upgrading.
>>
>> --
>> Douglas Guptill voice: 902-461-9749
>> Research Assistant, LSC 4640 email: douglas.guptill_at_[hidden]
>> Oceanography Department fax: 902-494-3877
>> Dalhousie University
>> Halifax, NS, B3H 4J1, Canada
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users