Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] How do I run OpenMPI safely on a Nehalem standalone machine?
From: Gus Correa (gus_at_[hidden])
Date: 2010-05-04 21:35:30


Hi Douglas

Yes, very helpful indeed!

The machine here is a two-way quad-core, and /proc/cpuinfo shows 16
processors, twice as much as the physical cores,
just like you see on yours.
So, HT is turned on for sure.

The security guard opened the office door for me,
and I could reboot that machine.
It's called Spinoza. Maybe that's why it is locked.
Now the door is locked again, so I will have to wait until tomorrow
to play around with the BIOS settings.

I will remember the BIOS double negative that you pointed out:
"When Disabled only one thread per core is enabled"
Ain't that English funny?
So far, I can't get no satisfaction.
Hence, let's see if Ralph's suggestion works.
Never get no hyperthreading turned on,
and you ain't have no problems with Open MPI. :)

Many thanks!
Have a great Halifax Spring time!

Cheers,
Gus

Douglas Guptill wrote:
> On Tue, May 04, 2010 at 05:34:40PM -0600, Ralph Castain wrote:
>> On May 4, 2010, at 4:51 PM, Gus Correa wrote:
>>
>>> Hi Ralph
>>>
>>> Ralph Castain wrote:
>>>> One possibility is that the sm btl might not like that you have hyperthreading enabled.
>>> I remember that hyperthreading was discussed months ago,
>>> in the previous incarnation of this problem/thread/discussion on "Nehalem vs. Open MPI".
>>> (It sounds like one of those supreme court cases ... )
>>>
>>> I don't really administer that machine,
>>> or any machine with hyperthreading,
>>> so I am not much familiar to the HT nitty-gritty.
>>> How do I turn off hyperthreading?
>>> Is it a BIOS or a Linux thing?
>>> I may try that.
>> I believe it can be turned off via an admin-level cmd, but I'm not certain about it
>
> The challenge was too great to resist, so I yielded, and rebooted my
> Nehalem (Core i7 920 @ 2.67 GHz) to confirm my thoughts on the issue.
>
> Entering the BIOS setup by pressing "DEL", and "right-arrowing" over
> to "Advanced", then "down arrow" to "CPU configuration", I found a
> setting called "Intel (R) HT Technology". The help dialogue says
> "When Disabled only one thread per core is enabled".
>
> Mine is "Enabled", and I see 8 cpus. The Core i7, to my
> understanding, is a 4 core chip.
>
> Hope that helps,
> Douglas.