Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] How do I run OpenMPI safely on a Nehalem standalone machine?
From: Douglas Guptill (douglas.guptill_at_[hidden])
Date: 2010-05-04 20:02:48


On Tue, May 04, 2010 at 05:34:40PM -0600, Ralph Castain wrote:
>
> On May 4, 2010, at 4:51 PM, Gus Correa wrote:
>
> > Hi Ralph
> >
> > Ralph Castain wrote:
> >> One possibility is that the sm btl might not like that you have hyperthreading enabled.
> >
> > I remember that hyperthreading was discussed months ago,
> > in the previous incarnation of this problem/thread/discussion on "Nehalem vs. Open MPI".
> > (It sounds like one of those supreme court cases ... )
> >
> > I don't really administer that machine,
> > or any machine with hyperthreading,
> > so I am not much familiar to the HT nitty-gritty.
> > How do I turn off hyperthreading?
> > Is it a BIOS or a Linux thing?
> > I may try that.
>
> I believe it can be turned off via an admin-level cmd, but I'm not certain about it

The challenge was too great to resist, so I yielded, and rebooted my
Nehalem (Core i7 920 @ 2.67 GHz) to confirm my thoughts on the issue.

Entering the BIOS setup by pressing "DEL", and "right-arrowing" over
to "Advanced", then "down arrow" to "CPU configuration", I found a
setting called "Intel (R) HT Technology". The help dialogue says
"When Disabled only one thread per core is enabled".

Mine is "Enabled", and I see 8 cpus. The Core i7, to my
understanding, is a 4 core chip.

Hope that helps,
Douglas.

-- 
  Douglas Guptill                       voice: 902-461-9749
  Research Assistant, LSC 4640          email: douglas.guptill_at_[hidden]
  Oceanography Department               fax:   902-494-3877
  Dalhousie University
  Halifax, NS, B3H 4J1, Canada