Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Not getting mpi.mod file from openmpi build and install
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2010-04-23 13:03:17


OMPI's configure script is probably somehow determining that it can't build the F90 bindings for some reason. Can you send the stdout/stderr from running configure, and your config.log? (please compress)

On Apr 22, 2010, at 8:10 PM, Price, Brian M (N-KCI) wrote:

> OpenMPI version: 1.3.3
> Platform: IBM P5
>
> If I configure with just the --prefix option for where to install, and then run “make all install”, I get an “mpi.mod” file in the “lib” directory of the prefix directory I specified. ALL GOOD!
>
> When I add compiler options to the configure script (e.g. “CC=xlC_r CXX=xlC_r FC=xlf95_r”), I no longer get the “mpi.mod” file.
>
> I have traced this to the Makefile in the “ompi/mpi/f90” directory. When I add the compiler options to the configure script, a bunch of lines get commented out of the Makefile, including the ones that look like they build the “mpi.mod” file.
>
> Can anyone tell me why this happens?
>
> Thanks.
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/