Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] unresolved symbol mca_base_param_reg_int
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2010-04-20 07:59:29


Gah! I didn't look at your error message closely enough the first time -- sorry!

Did you perchance upgrade an existing Open MPI installation in place? I.e., have Open MPI 1.2.7 installed in /somewhere and the install Open MPI 1.3.x/1.4.x into the same /somewhere?

If so, try a full uninstall of Open MPI 1.2.7 from /somewhere first -- or install Open MPI 1.4.x into /somewhere_else.

The reason is that Open MPI has a set of plugins that are not necessarily compatible between versions, and are not necessarily removed if you just install a new version over an old version.

On Apr 19, 2010, at 6:52 PM, Nev wrote:

> Hi Jeff,
> I have tried --disable-visibility but get the same results. Any other
> ideas? I am not able to remove the dlopen, but maybe able to move it to
> directly dlopen the mpi library, instead of my library that is linked to
> mpi. Is this likely to help?
> Nev
>
> On Mon, 2010-04-19 at 09:21 -0400, Jeff Squyres wrote:
> > It could well be because of the additional dlopen in your application (we changed some things from the 1.2 series with regards to this kind of stuff).
> >
> > Try configuring Open MPI with the --disable-visibility switch and see if that helps.
> >
> >
> > On Apr 17, 2010, at 9:05 PM, Nev wrote:
> >
> > > Hi,
> > > I am having a problem running application with OpenMpi version 1.4.1.
> > > The system works with version 1.2.7, but fails with version 1.3.4 and
> > > 1.4.1. (These are the only version I have tried).
> > >
> > > My application is linked against a shared library which does a dlopen of
> > > a 2nd shared "C" library which is compiled and linked using mpicc. The
> > > application and first shared library are C++.
> > > I rebuild and relink the 2nd shared library each time I change the
> > > openmpi build.
> > >
> > > When MPI_init is called I get the following error
> > > symbol lookup error: /opt/openmpi/lib/openmpi/mca_paffinity_linux.so:
> > > undefined symbol: mca_base_param_reg_int
> > >
> > > This does NOT occur with OpenMpi version 1.2.7, Or if I build OpenMpi as
> > > a static library, and then link against this static library.
> > >
> > > I am building a default openmpi except for --prefix=/opt/openmpi and
> > > --enable-static --disable-shared for static library build.
> > >
> > > I would link to be able to use non static openmpi build.
> > >
> > > Any suggestion on what I am doing wrong?
> > >
> > > Thanks Nev
> > >
> > >
> > >
> > >
> > > _______________________________________________
> > > users mailing list
> > > users_at_[hidden]
> > > http://www.open-mpi.org/mailman/listinfo.cgi/users
> > >
> >
> >
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/