Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] OS X - Can't find the absoft directory
From: Paul Cizmas (cizmas_at_[hidden])
Date: 2010-04-19 09:51:11


On Apr 19, 2010, at 8:43 AM, Ricardo Reis wrote:

> On Mon, 19 Apr 2010, Paul Cizmas wrote:
>
>> The ABSOFT is set and exported. I can double check this by doing
>> "echo $ABSOFT" and it appears that it is okay.
>
> Is it in the path? Besides being set, I mean...
>
> like
>
> export PATH=$ABSOFT:$PATH
>
> just trying to cover all corners...
>
> and maybe
>
> export PATH=$ABSOFT/bin:$PATH

Yes, it looks like this:

ABSOFT=/Applications/Absoft11.0
PATH=/opt/openmpi/bin:$PATH
PATH=$ABSOFT/bin:$PATH
export ABSOFT PATH

>
>
>> On Apr 19, 2010, at 7:11 AM, Jeff Squyres wrote:
>>
>>> Do you have your .bashrc configured such that it is run for /bin/
>>> sh as well? (I'm a tcsh user; forgive if this is a dumb question)
>>
>> I do not know this!!! How can I check it?
>
> hmmm, in many systems generally sh is just a simlink to bash...
>
> 2028.0 $ ls -l /bin/sh
> lrwxrwxrwx 1 root root 4 Sep 7 2009 /bin/sh -> bash

/bin/sh is not a link on my Mac OS X 10.5.8. I get this:

ls -l /bin/sh
-r-xr-xr-x 1 root wheel 1244960 May 23 2008 /bin/sh*
~$

>
>
>
> Ricardo Reis
>
> 'Non Serviam'
>
> PhD candidate @ Lasef
> Computational Fluid Dynamics, High Performance Computing, Turbulence
> http://www.lasef.ist.utl.pt
>
> Cultural Instigator @ Rádio Zero
> http://www.radiozero.pt
>
> Keep them Flying! Ajude a/help Aero Fénix!
>
> http://www.aeronauta.com/aero.fenix
>
> http://www.flickr.com/photos/rreis/
>
> < sent with alpine 2.00
> >_______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users