Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] openMPI configure/Installing problem onMacwithgnu-gcc-4.4.3 / gnu-gcc-4.5
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2010-04-19 09:11:22


On Apr 16, 2010, at 12:05 PM, Baowei Liu wrote:

> Thanks for your reply. Sorry I didn't make it clear..... When I run config.guess of gcc, it gives me the x86_64 system. But when I run "uname -a", it says it's i386. I think that's the reason OMPI complains about "more than one -arch option (not allowed, use cc(1) instead)".

What do you mean? I don't think you've mentioned that before...?

> The new gcc can create executibals. I use it to compile my own c++ programs. And I don't need special flags. I need a higher version of gcc than the default one just because I cannot build a package (QE:Quantum Espresso) with the default gcc -- QE uses OMPI. I can install OMPI with the default gcc. I tried this:
>
> 1. install OMPI with default gcc and OMPI works fine.
> 2. install the new gcc and install the QE package, successfully.
> 3. mpirun stops working with eorror" cannot initialize"

This is the first time you've mentioned this, too. :-)

Did you re-install Open MPI with the new gcc (and no -m flags, etc.)? If that doesn't work, please send all the information listed here:

    http://www.open-mpi.org/community/help/

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/