Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] OS X - Can't find the absoft directory
From: Paul Cizmas (cizmas_at_[hidden])
Date: 2010-04-16 19:18:35


Hello:

I am trying to install openmpi with Absoft on Mac running OS X
10.5.8. When I do "sudo make all install", the installation ends with
the following message:

Making all in scripts
make[4]: Nothing to be done for `all'.
/bin/sh ../../../libtool --mode=compile /Applications/Absoft11.0/bin/
f90 -I../../../ompi/include -I../../../ompi/include -p. -I. -I../../../
ompi/mpi/f90 -m64 -lU77 -c -o mpi.lo mpi.f90
libtool: compile: /Applications/Absoft11.0/bin/f90 -I../../../ompi/
include -I../../../ompi/include -p. -I. -I../../../ompi/mpi/f90 -m64 -
lU77 -c mpi.f90 -o .libs/mpi.o
Can't find the absoft directory.
Please set the ABSOFT environment variable and try again.
make[4]: *** [mpi.lo] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1

==========================================

I tried to add in the makefile the following line

ABSOFT = /Applications/Absoft11.0

but this did not help. I wonder if this definition of ABSOFT must be
added to another file. If so, what this file should be?

Thank you,
Paul