Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Fwd: Open MPI v1.4 cant find default hostfile
From: Mario Ogrizek (mario.guardian_at_[hidden])
Date: 2010-04-16 18:52:34


I understand, so, its looking for a
working_dir/usr/local/etc/openmpi-default-hostfile
I managed to run a hello world program from the console, while my wd was
just "/" and it worked, altho strangely...
example for 4 procs:

Hello MPI World From process 0: Num processes: 1
Hello MPI World From process 0: Num processes: 1
Hello MPI World From process 0: Num processes: 1
Hello MPI World From process 0: Num processes: 1

So, you are saying i allways have to be in "/" to run mpi programs, or there
is a way for mpi to search absolute path?
It seems pretty inconvinient this way.
I think v 1.2 didnt have this limitation.

Does this have to do anything with LD_LIBRARY_PATH?

Regards,

Mario

On Fri, Apr 16, 2010 at 7:46 PM, Ralph Castain <rhc_at_[hidden]> wrote:

> How did you specify it? Command line? Default MCA param file?
>
> On Apr 16, 2010, at 11:44 AM, Mario Ogrizek wrote:
>
> Any idea how to solve this?
>
> On Fri, Apr 16, 2010 at 7:40 PM, Timur Magomedov <
> timur.magomedov_at_[hidden]> wrote:
>
>> Hello.
>> It looks that you hostfile path should
>> be /usr/local/etc/openmpi-default-hostfile not
>> usr/local/etc/openmpi-default-hostfile but somehow Open MPI gets the
>> second path.
>>
>> В Птн, 16/04/2010 в 19:10 +0200, Mario Ogrizek пишет:
>> > Well, im not sure why should i name it /openmpi-default-hostfile
>> > Especially, because mpirun v1.2 executes without any errors.
>> > But, i made a copy named /openmpi-default-hostfile, and still, the
>> > same result.
>> >
>> > This is the whole error message for a simple hello world program:
>> >
>> >
>> > Open RTE was unable to open the hostfile:
>> > usr/local/etc/openmpi-default-hostfile
>> > Check to make sure the path and filename are correct.
>> >
>> --------------------------------------------------------------------------
>> > [Mario.local:04300] [[114,0],0] ORTE_ERROR_LOG: Not found in file
>> > base/ras_base_allocate.c at line 186
>> > [Mario.local:04300] [[114,0],0] ORTE_ERROR_LOG: Not found in file
>> > base/plm_base_launch_support.c at line 72
>> > [Mario.local:04300] [[114,0],0] ORTE_ERROR_LOG: Not found in file
>> > plm_rsh_module.c at line 990
>> >
>> --------------------------------------------------------------------------
>> > A daemon (pid unknown) died unexpectedly on signal 1 while attempting
>> > to
>> > launch so we are aborting.
>> >
>> >
>> > There may be more information reported by the environment (see above).
>> >
>> >
>> > This may be because the daemon was unable to find all the needed
>> > shared
>> > libraries on the remote node. You may set your LD_LIBRARY_PATH to have
>> > the
>> > location of the shared libraries on the remote nodes and this will
>> > automatically be forwarded to the remote nodes.
>> >
>> --------------------------------------------------------------------------
>> >
>> --------------------------------------------------------------------------
>> > mpirun noticed that the job aborted, but has no info as to the process
>> > that caused that situation.
>> >
>> --------------------------------------------------------------------------
>> > mpirun: clean termination accomplished
>> >
>> >
>> >
>> >
>> > ps. PTP is a parallel tools platform plugin for eclipse
>> >
>> >
>> > Regards,
>> >
>> >
>> > Mario
>> >
>> > _______________________________________________
>> > users mailing list
>> > users_at_[hidden]
>> > http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
>> --
>> Kind regards,
>> Timur Magomedov
>> Senior C++ Developer
>> DevelopOnBox LLC / Zodiac Interactive
>> http://www.zodiac.tv/
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>