Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Fwd: Open MPI v1.4 cant find default hostfile
From: Mario Ogrizek (mario.guardian_at_[hidden])
Date: 2010-04-16 13:10:48


Well, im not sure why should i name it /openmpi-default-hostfile
Especially, because mpirun v1.2 executes without any errors.
But, i made a copy named /openmpi-default-hostfile, and still, the same
result.

This is the whole error message for a simple hello world program:

Open RTE was unable to open the hostfile:
    usr/local/etc/openmpi-default-hostfile
Check to make sure the path and filename are correct.
--------------------------------------------------------------------------
[Mario.local:04300] [[114,0],0] ORTE_ERROR_LOG: Not found in file
base/ras_base_allocate.c at line 186
[Mario.local:04300] [[114,0],0] ORTE_ERROR_LOG: Not found in file
base/plm_base_launch_support.c at line 72
[Mario.local:04300] [[114,0],0] ORTE_ERROR_LOG: Not found in file
plm_rsh_module.c at line 990
--------------------------------------------------------------------------
A daemon (pid unknown) died unexpectedly on signal 1 while attempting to
launch so we are aborting.

There may be more information reported by the environment (see above).

This may be because the daemon was unable to find all the needed shared
libraries on the remote node. You may set your LD_LIBRARY_PATH to have the
location of the shared libraries on the remote nodes and this will
automatically be forwarded to the remote nodes.
--------------------------------------------------------------------------
--------------------------------------------------------------------------
mpirun noticed that the job aborted, but has no info as to the process
that caused that situation.
--------------------------------------------------------------------------
mpirun: clean termination accomplished

ps. PTP is a parallel tools platform plugin for eclipse

Regards,

Mario