Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] btl_tcp_if_exclude param
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2010-04-13 09:08:48


On Apr 13, 2010, at 9:03 AM, Gabriele Fatigati wrote:

> ompi_info --param btl tcp

Ah ha... this is revealing:

> MCA btl: parameter "btl" (current value: "^tcp", data source: file
> [/cineca/prod/opt/compilers/openmpi/1.3.3/intel--11.1--binary/etc/openmpi-mca-params.conf])
> Default selection set of components for the btl framework (<none> means use all components that can be found)

It seems you have a config file /cineca/prod/opt/compilers/openmpi/1.3.3/intel--11.1--binary/etc/openmpi-mca-params.conf that is excluding the TCP BTL from being used.

This config file will even prevent the TCP BTL from being shown in ompi_info -- remember that ompi_info shows *current* values of MCA parameters. So you might want to do something like this:

    ompi_info --mca btl "" --param btl tcp

That would override the "btl" MCA parameter in your config file, allow the BTL TCP to be loaded by ompi_info, and therefore show you all the BTL TCP params.

Make sense?

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/