Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: [OMPI users] openMPI configure/Installing problem on Mac with gnu-gcc-4.4.3 / gnu-gcc-4.5
From: Baowei Liu (bliu520_at_[hidden])
Date: 2010-04-11 23:48:18


Hi all,

I installed gnu-gcc-4.4.3 on our Mac and found out openMPI didn't work any
longer. I tried a lot of things to install openMPI back but failed. I
installed the new gnu-gcc-4.5 and got similar problem.

I followed the information on this mailing list and used option "-arch
x86_64" for compilers to try to get rid of the following error:

as: more than one -arch option (not allowed, use cc(1) instead)
make[2]: *** [coll_hierarch.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1

I tried two ways:

1.
./configure --prefix=/usr/local/openmpi --enable-static CC=gcc FC=gfortran
F77=gfortran CXX=g++ CFLAGS="-arch x86_64" CXXFLAGS="-arch x86_64"
FCFLAGS="-m64 -arch x86_64" FFLAGS="-m64 -arch x86_64" --with-gnu-ld

Configure failed. It seems the configure doesn't recognize the option
-arch x86_64

Then I did
2.
export CFLAGS="-arch x86_64"
export CXXFLAGS="-arch x86_64"
export FCFLAGS="-m64 -arch x86_64"
export FFLAGS="-m64 -arch x86_64"
export OBJCFLAGS="-arch x86_64"
export
DYLD_LIBRARY_PATH=/usr/local/gcc-4.5/lib/gcc/x86_64-apple-darwin10.2.0/4.6.0/include

./configure --prefix=/usr/local/openmpi CC=gcc FC=gfortran F77=gfortran
CXX=g++ --with-gnu-ld

Configure passed but it gave same making error.

Any hint?

Thanks,
Bill