Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] openMPI on Xgrid
From: Ralph Castain (rhc_at_[hidden])
Date: 2010-03-29 15:07:51


Our xgrid support has been broken for some time now due to lack of access to a test environment. So your system is using rsh/ssh instead.

Until we get someone interested in xgrid, or at least willing to debug it and tell us what needs to be done, I'm afraid our xgrid support will be lacking.

On Mar 29, 2010, at 12:56 PM, Cristobal Navarro wrote:

> Hello,
> i am new on this mailing list!
> i've read the other messages about configuring openMPI on Xgrid, but i havent solved my problem yet and openMPI keeps running as if Xgrid didnt exist.
>
> i configured xgrid properly, and can send simple C program jobs trough the command line from my client, which is the same as the controller and the same as the agent for the moment.
> >> xgrid -h localhost -p pass -job run ./helloWorld
> i also installed xgrid Admin for monitoring.
>
> then,
> i compiled openMPI 1.4.1 with these options
>
> /configure --prefix=/usr/local/openmpi/ --enable-shared --disable-static --with-xgrid
> sudo make
> sudo make install
>
> and i made a simple helloMPI example.
>
>
> /* MPI C Example */
> #include <stdio.h>
> #include <mpi.h>
>
> int main (argc, argv)
> int argc;
> char *argv[];
> {
> int rank, size;
>
> MPI_Init (&argc, &argv); /* starts MPI */
> MPI_Comm_rank (MPI_COMM_WORLD, &rank); /* get current process id */
> MPI_Comm_size (MPI_COMM_WORLD, &size); /* get number of processes */
> printf( "Hello world from process %d of %d\n", rank, size );
> MPI_Finalize();
> return 0;
> }
>
> and compiled succesfully
>
> >> mpicc hellompi.c -o hellompi
>
> the i run it
>
> >> mpirun -np 2 hellompi
> I am running on ijorge.local
> Hello World from process 0 of 2
> I am running on ijorge.local
> Hello World from process 1 of 2
>
> the results are correct, but when i check Xgrid Admin, i see that the execution didnt go trought Xgrid since there arent any new jobs on the list.
> in the end, openMPI and Xgrid are not comunicating to each other.
>
> what am i missing??
>
> my enviroment variables are these:
>
> >>echo $XGRID_CONTROLLER_HOSTNAME
> ijorge.local
> >>echo $XGRID_CONTROLLER_PASSWORD
> myPassword
>
>
> any help is welcome!!
> thanks in advance
>
> Cristobal
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users