Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Non-root install; hang there running on multiple nodes
From: haoanyi (haoanyi_at_[hidden])
Date: 2010-03-24 16:36:58


Yes, I can do all of these on each node.

In 2010-03-25 04:33:24, "Jeff Squyres" <jsquyres_at_[hidden]> wrote :

>Can you mpirun non-MPI applications, like "hostname"? I frequently run this as a first step to debugging a wonky install. For example:
>
>shell$ hostname
>barney
>shell$ mpirun hostname
>barney
>shell$ cat hosts
>barney
>rubble
>shell$ mpirun --hostfile hosts hostname
>barney
>rubble
>shell$
>
>
>On Mar 24, 2010, at 4:28 PM, haoanyi wrote:
>
>> Hi,
>>
>> I installed OpenMPI1.4.1 as a non-root user on a cluster. It is totally OK when I run with mpirun or mpiexec on one single node for many processes. However, when I lauch many processes on multiple nodes, I can observe jobs are distributed to those nodes (by using "top"), but all the jobs just hang there and cannot finish.
>>
>> I think the nodes use TCP to communicate with each other. This cluster also provides MPICH2, which was configured by the sys admin., and has no problem to do node communication in MPICH2. Besides, I read from some posts, which says this may be caused by TCP firewall. Since I have no root's right, and I don't know what shall request the admin. to do to fix this problem. So, can you tell me how to do that either by the admin root or by the non-root user (if possible)?
>>
>> Thank you very much.
>> Hao
>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>--
>Jeff Squyres
>jsquyres_at_[hidden]
>For corporate legal information go to:
>http://www.cisco.com/web/about/doing_business/legal/cri/
>
>
>_______________________________________________
>users mailing list
>users_at_[hidden]
>http://www.open-mpi.org/mailman/listinfo.cgi/users