Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] mpirun with -am ft-enable-cr option runs slow if hyperthreading is disabled
From: ananda.mudar_at_[hidden]
Date: 2010-03-22 16:41:51


Hi

 

If the run my compute intensive openmpi based program using regular
invocation of mpirun (ie; mpirun -host <hostnamelist> -np <number of
cores>), it gets completed in few seconds but if I run the same program
with "-am ft-enable-cr" option, the program takes 10x time to complete.

 

If I enable hyperthreading on my cluster nodes and then call mpirun with
"-am ft-enable-cr" option, the program gets completed with few
additional seconds than the normal mpirun!!

 

How can I improve the performance of mpirun with "-am ft-enable-cr"
option when I disable hyperthreading on my cluster nodes? Any pointers
will be really useful.

 

FYI, I am using openmpi 1.3.4 library and BLCR 0.8.2. Cluster nodes are
Nehalem based nodes with 8 cores.

 

Thanks
Anand

Please do not print this email unless it is absolutely necessary. The information contained in this electronic message and any attachments to this message are intended for the exclusive use of the addressee(s) and may contain proprietary, confidential or privileged information. If you are not the intended recipient, you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately and destroy all copies of this message and any attachments. WARNING: Computer viruses can be transmitted via email. The recipient should check this email and any attachments for the presence of viruses. The company accepts no liability for any damage caused by any virus transmitted by this email. www.wipro.com