Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Windows: problems running on a second system.
From: cjohnson_at_[hidden]
Date: 2010-03-16 12:41:14


Like I said initially, these are two Windows 7 boxes. Could that be a difference?

Charlie ...
-------- Original Message --------
Subject: Re: [OMPI users] Windows: problems running on a second system.
From: Shiqing Fan <fan@hlrs.de>
Date: Tue, March 16, 2010 5:52 am
To: cjohnson@valverdecomputing.com
Cc: Open MPI Users <users@open-mpi.org>


Hi Charlie,

I have tested with creating a new user on my Windows XP box, and
everything works just fine, wmic can launch remote process without problem.

There are several possibilities that the "Access is denied" could
happen. It could be the DCOM setting is wrong, i.e. the user doesn't
have the permission to use it; or it could also be that the user
name/password provided is not correct, so that the authentication just
fails. However, your settings look good to me.


Regards,
Shiqing



cjohnson@valverdecomputing.com wrote:
> No, I granted everything, clicked all the boxes.
>
> In DCOMCNFG.exe, got to the COM Security tab, there are two "edit
> limits" sections, for Access Permissions and for Launch and Activation
> Permissions. I added myself as a user in both, and granted all 2
> permissions in the first, and all 4 permissions in the second.
>
> Charlie ...
>
> -------- Original Message --------
> Subject: Re: [OMPI users] Windows: problems running on a second
> system.
> From: Shiqing Fan <fan@hlrs.de>
> Date: Tue, March 16, 2010 2:33 am
> To: cjohnson@valverdecomputing.com
> Cc: Open MPI Users <users@open-mpi.org>
>
> Hi,
>
> The lower case in the mpirun warning message shouldn't matter, as
> long
> as the wmic launch doesn't work, mpirun doesn't neither.
>
> According to your description, I think you missed some settings in
> DCOMCNFG, that you probably have to grant the user "remote
> activation"
> and "remote launch" permissions in the "launch and activation
> permissions" section; the local/remote access permissions don't help.
>
>
> Regards,
> Shiqing
>
>
>
> cjohnson@valverdecomputing.com wrote:
> > I went and did this in every conceivable combination of ways. I did
> > the *DCOMCNFG* thing with both the launch and the remote access
> > permissions, granting my local logon on each node everything. Then I
> > did the namespaces with *wmimgmt.msc*, first on every object in both
> > the CIMV2 (which had ms_409 and Applications branches) and DEFAULT
> > (which had an ms_409 branch), and then on the CIMV2 and DEFAULT
> > namespaces themselves, granting every checkbox permission.
> >
> > Nothing changed, same error code which is a "DCOM access denied"
> error.
> >
> > I noticed that the name mentioned in the error from mpirun is
> cimv2 in
> > lower case, while the namespace in WMI security box is upper case
> > CIMV2. Is that a problem?
> >
> > Charlie ...
> >
> > -------- Original Message --------
> > Subject: Re: [OMPI users] Windows: problems running on a second
> > system.
> > From: Shiqing Fan <fan@hlrs.de>
> > Date: Mon, March 15, 2010 3:18 am
> > To: cjohnson@valverdecomputing.com
> > Cc: Open MPI Users <users@open-mpi.org>
> >
> >
> > Hi Johnson,
> >
> > I was trying to reproduce it, so that I could give you a direct
> > solution. The problem might be the DCOM configure is not correct.
> > Have
> > you done it as described in this link:
> > http://msdn.microsoft.com/en-us/library/aa393266(VS.85).aspx
> <http://msdn.microsoft.com/en-us/library/aa393266%28VS.85%29.aspx>
> > <http://msdn.microsoft.com/en-us/library/aa393266%28VS.85%29.aspx>,
> > you need
> > give the user "remote activate" permission on namespace CIMV2 and
> > DEFAULT.
> >
> >
> > Regards,
> > Shiqing
> >
> >
> > cjohnson@valverdecomputing.com wrote:
> > > Finally got a second development system procured and up and
> running.
> > >
> > > Got things working pretty wellon one node, installed on the
> > second and
> > > things work there.
> > >
> > > This may be a similar problem to Charles Shuller's a month ago,
> > maybe
> > > not. Tried to launch a program from node work on node work2:
> > >
> > > C:\prog\mon\debug>mpirun -npernode 1 -host work2
> > > C:\prog\mon\examples\solvers\C\sjacobi.exe
> > > connecting to work2
> > > username:charles johnson
> > > password:**********
> > > Save Credential?(Y/N) y
> > > [Work:03468] This feature hasn't been implemented yet.
> > > [Work:03468] Could not connect to namespace cimv2 on node work2.
> > Error
> > > code =-2147024891
> > >
> --------------------------------------------------------------------------
> > > mpirun was unable to start the specified application as it
> > encountered
> > > an error.
> > > More information may be available above.
> > >
> --------------------------------------------------------------------------
> > >
> > > So I tried some of the things you asked from him:
> > >
> > > C:\prog\mon\debug>wmic /node:192.168.1.37 /user:"charles johnson"
> > > process call create notepad.exe
> > > Enter the password :**********
> > >
> > > ERROR:
> > > Description = Access is denied.
> > >
> > > Then I tried this:
> > >
> > > C:\prog\mon\debug>mpirun -np 1 -host work2 notepad.exe
> > > connecting to work2
> > > username:charles johnson
> > > password:**********
> > > Save Credential?(Y/N) n
> > > [Work:03108] Could not connect to namespace cimv2 on node work2.
> > Error
> > > code =-2147024891
> > >
> --------------------------------------------------------------------------
> > > mpirun was unable to start the specified application as it
> > encountered
> > > an error.
> > > More information may be available above.
> > >
> --------------------------------------------------------------------------
> > >
> > > My case may be simpler than his, some misconfiguration or
> something.
> > >
> > > As before: <openmpi-1.4.tar.gz>, built with <cmake-2.6.4-win32-x86>
> > > using the VC++ info below (probably more than you want):
> > >
> > > Microsoft Visual Studio 2005
> > > Version 8.0.50727.867 (vsvista.050727-8600)
> > > Microsoft .NET Framework
> > > Version 2.0.50727 SP2
> > >
> > > Installed Edition: Enterprise Architect
> > >
> > > Microsoft Visual C++ 2005 77637-163-9000005-41563
> > > Microsoft Visual C++ 2005
> > >
> > > Microsoft Visual Studio 2005 Team Edition for Software Architects -
> > > ENU Service Pack 1 (KB926601)
> > >
> > > Security Update for Microsoft Visual Studio 2005 Team Edition for
> > > Software Architects - ENU (KB937061)
> > >
> > > Security Update for Microsoft Visual Studio 2005 Team Edition for
> > > Software Architects - ENU (KB971023)
> > >
> > > Security Update for Microsoft Visual Studio 2005 Team Edition for
> > > Software Architects - ENU (KB971090)
> > >
> > > Security Update for Microsoft Visual Studio 2005 Team Edition for
> > > Software Architects - ENU (KB973673)
> > >
> > > Update for Microsoft Visual Studio 2005 Team Edition for Software
> > > Architects - ENU (KB932232)
> > >
> > > Thanks in advance for any kind help.
> > >
> > > C.S. Johnson
> > >
> > >
> ------------------------------------------------------------------------
> > >
> > > _______________________________________________
> > > users mailing list
> > > users@open-mpi.org
> > > http://www.open-mpi.org/mailman/listinfo.cgi/users
> >
> >
> > --
> > --------------------------------------------------------------
> > Shiqing Fan http://www.hlrs.de/people/fan
> > High Performance Computing Tel.: +49 711 685 87234
> > Center Stuttgart (HLRS) Fax.: +49 711 685 65832
> > Address:Allmandring 30 email: fan@hlrs.de
> > 70569 Stuttgart
> >
>
>
> --
> --------------------------------------------------------------
> Shiqing Fan http://www.hlrs.de/people/fan
> High Performance Computing Tel.: +49 711 685 87234
> Center Stuttgart (HLRS) Fax.: +49 711 685 65832
> Address:Allmandring 30 email: fan@hlrs.de
> 70569 Stuttgart
>


--
--------------------------------------------------------------
Shiqing Fan http://www.hlrs.de/people/fan
High Performance Computing Tel.: +49 711 685 87234
Center Stuttgart (HLRS) Fax.: +49 711 685 65832
Address:Allmandring 30 email: fan@hlrs.de
70569 Stuttgart