Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] pipe function call failed...
From: Lasse Kliemann (lasse-list-openmpi-2010_at_[hidden])
Date: 2010-03-09 11:40:17


$ mpirun -n 1 ls
--------------------------------------------------------------------------
mpirun was unable to launch the specified application as it encountered an error:

Error: pipe function call failed when setting up I/O forwarding subsystem
Node: xxxxx.xxxxxxxxxx.xxxxxxxx.xx

while attempting to start process rank 0.
--------------------------------------------------------------------------

I receive this error constantly. I tracked it down so far that it
appears now certain that the 'tcgetattr' and 'tcsetattr' calls in
'orte/mca/iof/base/iof_base_setup.c' are responsible. 'errno' is
set to 22 each, which means 'invalid argument'. We can simply
ignore the return values of these calls and continue, as done in
the attached patch. Some simple tests suggest that everything
else is fine, but I haven't tested thoroughly yet.

On another system, this problem is absent. The main difference
are GCC and Glibc versions. The problematic system uses GCC 4.3.4
and Glibc 2.11.1 -- which is the newest Glibc release and maybe
untested yet with OpenMPI.

Let me know which additional information I can provide to further
analyze this issue.




  • text/plain attachment: patch

  • application/pgp-signature attachment: stored