Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] configure error
From: Rainer Keller (keller_at_[hidden])
Date: 2010-02-24 08:59:30


Dear Rockhee Sung,
Your explanation on which variant (1,2 or 3) gave which error message. I
assume, the output You provided is from variant 1.

Not having an Apple MAC at hand, the F77 compiler gfortran here complains
about:
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
configure:35830: gfortran -o conftest conftest.f conftest_c.o >&5
ld: warning: in conftest_c.o, file is not of required architecture
Undefined symbols:
  "_testfunc_", referenced from:
      _MAIN__ in ccx8DXUy.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
configure:35837: $? = 1
configure: failed program was:
| program main
|
| external testfunc
| call testfunc(1)
|
| end
configure:35875: result: no
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

You may want to pass the same -arch flags for non-fat binaries to the F90
compiler (here again gfortran) using FCFLAGS, aka:

../configure FCFLAGS='-arch x86_64' FFLAGS='-arch x86_64' CFLAGS='-arch
x86_64' CXXFLAGS='-arch x86_64'

Best regards,
Rainer

On Wednesday 24 February 2010 08:01:53 am Admin wrote:
> Hi there,
>
> I tried 3 different ways.
> (1)./configure
> (2)../configure CFLAGS='-arch x86_64' CXXFLAGS='-arch x86_64'
> (3)../configure FFLAGS='-arch x86_64' CFLAGS='-arch x86_64' CXXFLAGS='-arch
> x86_64'
>
> (1) and (2) gave same error but for (3), error shows such as below..
> Does it mean different default build options between compilers? If so, how
> can I solve it out then?
>
> *** Fortran 77 compiler
> checking for gfortran... gfortran
> checking whether we are using the GNU Fortran 77 compiler... no
> checking whether gfortran accepts -g... yes
> checking if Fortran 77 compiler works... no
> **********************************************************************
> * It appears that your Fortran 77 compiler is unable to produce working
> * executables. A simple test application failed to properly
> * execute. Note that this is likely not a problem with Open MPI,
> * but a problem with the local compiler installation. More
> * information (including exactly what command was given to the
> * compiler and what error resulted when the command was executed) is
> * available in the config.log file in this directory.
> **********************************************************************
> configure: error: Could not run a simple Fortran 77 program. Aborting.
> -------------------------------------
>

-- 
------------------------------------------------------------------------
Rainer Keller, PhD                  Tel: +1 (865) 241-6293
Oak Ridge National Lab          Fax: +1 (865) 241-4811
PO Box 2008 MS 6164           Email: keller_at_[hidden]
Oak Ridge, TN 37831-2008    AIM/Skype: rusraink