Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Error while configuring openmpi with pgi
From: vighnesh_at_[hidden]
Date: 2010-02-16 06:01:08


Hi,
   I am using PGI compiler version 7.2.4, in my Linux cluster, configured
with MPICH1. I tried to configure OPENMPI-1.3.3 with this PGI compiler,
but with no success. While performing #make it gives the following
error:

___________________________________________________________________________

Making install in scripts
make[4]: Entering directory `/tmp/openmpi-1.3.3/ompi/mpi/f90/scripts'
make[5]: Entering directory `/tmp/openmpi-1.3.3/ompi/mpi/f90/scripts'
make[5]: Nothing to be done for `install-exec-am'.
make[5]: Nothing to be done for `install-data-am'.
make[5]: Leaving directory `/tmp/openmpi-1.3.3/ompi/mpi/f90/scripts'
make[4]: Leaving directory `/tmp/openmpi-1.3.3/ompi/mpi/f90/scripts'
make[4]: Entering directory `/tmp/openmpi-1.3.3/ompi/mpi/f90'
/bin/sh ../../../libtool --mode=link pgf90 -I../../../ompi/include
-I../../../ompi/include -I. -I. -I../../../ompi/mpi/f90 -export-dynamic
  -o libmpi_f90.la -rpath
/share/apps/pgi-7.2.4/linux86-64/7.2/mpi/openmpi/lib mpi.lo mpi_sizeof.lo
mpi_comm_spawn_multiple_f90.lo mpi_testall_f90.lo mpi_testsome_f90.lo
mpi_waitall_f90.lo mpi_waitsome_f90.lo mpi_wtick_f90.lo mpi_wtime_f90.lo
../../../ompi/libmpi.la -lnsl -lutil -lm
libtool: link: pgf90 -shared -fpic -Mnomain .libs/mpi.o
.libs/mpi_sizeof.o .libs/mpi_comm_spawn_multiple_f90.o
.libs/mpi_testall_f90.o .libs/mpi_testsome_f90.o .libs/mpi_waitall_f90.o
.libs/mpi_waitsome_f90.o .libs/mpi_wtick_f90.o .libs/mpi_wtime_f90.o
-Wl,-rpath -Wl,/tmp/openmpi-1.3.3/ompi/.libs -Wl,-rpath
-Wl,/tmp/openmpi-1.3.3/orte/.libs -Wl,-rpath
-Wl,/tmp/openmpi-1.3.3/opal/.libs -Wl,-rpath
-Wl,/share/apps/pgi-7.2.4/linux86-64/7.2/mpi/openmpi/lib
-L/tmp/openmpi-1.3.3/orte/.libs -L/tmp/openmpi-1.3.3/opal/.libs
../../../ompi/.libs/libmpi.so /tmp/openmpi-1.3.3/orte/.libs/libopen-rte.so
/tmp/openmpi-1.3.3/opal/.libs/libopen-pal.so -ldl -lnsl -lutil -lm
-pthread -Wl,-soname -Wl,libmpi_f90.so.0 -o .libs/libmpi_f90.so.0.0.0
pgf90-Error-Unknown switch: -pthread
make[4]: *** [libmpi_f90.la] Error 1
make[4]: Leaving directory `/tmp/openmpi-1.3.3/ompi/mpi/f90'
make[3]: *** [install-recursive] Error 1
make[3]: Leaving directory `/tmp/openmpi-1.3.3/ompi/mpi/f90'
make[2]: *** [install] Error 2
make[2]: Leaving directory `/tmp/openmpi-1.3.3/ompi/mpi/f90'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/tmp/openmpi-1.3.3/ompi'
make: *** [install-recursive] Error 1
____________________________________________________________________________

   Can anyone please help me in solving this problem.

Thankyou,

Regards,
Vighnesh