Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] openmpi errors on ubuntu:no connectivity
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2010-02-09 15:34:16


Is there any chance you can upgrade to Open MPI v1.4? 1.2.x. is fairly ancient.

Upgrading to 1.4.x will fix the "unable to find any HCAs..." warning message.

For the a.out message, however, it is generally easiest to have the executable available on all nodes in the same filesystem location. For small clusters, using NFS can be convenient here. E.g., NFS share /home, and have your a.out under /home/mpi/a.out. Then you can mpirun -np 2 --host a,b /home/mpi/a.out.

On Feb 9, 2010, at 2:17 PM, swagat mishra wrote:

> hello,
> we have installed open mpi 1.2 using synaptic package manager in 2 machines running on ubuntu 8.10 and ubuntu 8.04.the hello.c program runs correctly,but connectivity_c.c program included in the openmpi tarball example fails when we it tries to communicate between both computers.also on the 8.04 version we get an error of "unable to find any HCA's will use another transport instead".on the 8.10 machine we get an error "unable to find executable:a.out host:ip of node".
> however the programs run without errors when we specify only localhost in hostfile.we have set up PATH and LD_LIBRARY_PATH,but still get same errors.
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/