Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] INSTALL bug in 64-bit build of OpenMPI Release build on Windows - has workaround
From: Shiqing Fan (fan_at_[hidden])
Date: 2010-02-04 12:18:45


Hi Marcus,

I don't think it's correct to set CMAKE_CL_64 explicitly in CMake-GUI,
it's a variable describing the system.

And it's not a good idea to use "Configuration Manager" to adapt another
configuration, if you really want to do so, you have to also adjust each
project property to fit the new configuration, e.g. from x86 to x64
settings. If you already have an x86 solution, and you want to have
another for x64, you have to start over from the CMake-GUI, select the
64 bit generator, i.e. "Visual Studio 9 2008 64bit", so that to generate
the a new solution in a different directory.

Regards,
Shiqing

Marcus G. Daniels wrote:
> Hi,
>
> I have another problem with building x86_64 on 64 bit Windows 7. I set
> CMAKE_CL_64 to true in cmake-gui, and and set the VS2008 config to x64
> (`New' platform adapted from WIN32). However, I get this during the
> build:
>
> 1>------ Build started: Project: libopen-pal, Configuration: Debug x64 ------
> 1>Linking...
> 1>.\x64\Debug\keyval_lex.obj : fatal error LNK1112: module machine type
> 'x64' conflicts with target machine type 'X86'
> 1>Build log was saved at
> "file://c:\cygwin\home\mdaniels\build\ompi-trunk-cmake\opal\x64\Debug\BuildLog.htm"
> 1>libopen-pal - 1 error(s), 0 warning(s)
> ========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========
>
> It's not obvious where X86 enters the picture..
>
> Marcus
>

-- 
--------------------------------------------------------------
Shiqing Fan                          http://www.hlrs.de/people/fan
High Performance Computing           Tel.: +49 711 685 87234
  Center Stuttgart (HLRS)            Fax.: +49 711 685 65832
Address:Allmandring 30               email: fan_at_[hidden]    
70569 Stuttgart