Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] INSTALL bug in 64-bit build of OpenMPI Release build on Windows - has workaround
From: Damien Hocking (damien_at_[hidden])
Date: 2010-02-03 19:10:03


Hi all,

There might be some minor bugs in the 64-bit CMake Visual Studio Install
project on Windows (say that 3 times fast...). When I build a 64-bit
release version, the install is still set up for installing pdbs, even
though it's a release build. This is for VS2008 on Windows 7, CMake
2.6.4. The offending sections are below, and the install works if you
delete these sections yourself. It doesn't happen on 32-bit release
installs.

opal cmake.install.cmake

IF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}" STREQUAL
"Unspecified")
   FILE(INSTALL DESTINATION "${CMAKE_INSTALL_PREFIX}/bin" TYPE FILE
FILES "C:/projects2/openmpi-1.4.1/build64/Debug/libopen-pald.pdb")
ENDIF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}"
STREQUAL "Unspecified")

ompi cmake.install.cmake

IF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}" STREQUAL
"Unspecified")
   FILE(INSTALL DESTINATION "${CMAKE_INSTALL_PREFIX}/bin" TYPE FILE
FILES "C:/projects2/openmpi-1.4.1/build64/Debug/libmpid.pdb")
ENDIF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}"
STREQUAL "Unspecified")

ompi/mpi/cxx cmake.install.cmake

IF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}" STREQUAL
"Unspecified")
   FILE(INSTALL DESTINATION "${CMAKE_INSTALL_PREFIX}/bin" TYPE FILE
FILES "C:/projects2/openmpi-1.4.1/build64/Debug/libmpi_cxxd.pdb")
ENDIF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}"
STREQUAL "Unspecified")

orte cmake.install.cmake

IF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}" STREQUAL
"Unspecified")
   FILE(INSTALL DESTINATION "${CMAKE_INSTALL_PREFIX}/bin" TYPE FILE
FILES "C:/projects2/openmpi-1.4.1/build64/Debug/libopen-rted.pdb")
ENDIF(NOT CMAKE_INSTALL_COMPONENT OR "${CMAKE_INSTALL_COMPONENT}"
STREQUAL "Unspecified")

Damien