Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Configuring OpenMPI 1.3.3, 1.4 --with-valgrind 3.5.0
From: Conboy, James (Jim.Conboy_at_[hidden])
Date: 2010-02-03 09:25:57


Thats correct, I set with-valgrind to point to the source directory..
Initially, I intended to use the valgrind distributed with Fedora 10,
but that has no header files included - so after Id downloaded the
valgrind source, it seemed like the next thing to try.

It works fine with the installation directory . Now for the tricky bit,
finding the leak(s)..

Thanks for the rapid reply -
Jim

-----Original Message-----
From: users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]] On
Behalf Of Jeff Squyres
Sent: 02 February 2010 23:06
To: Open MPI Users
Subject: Re: [OMPI users] Configuring OpenMPI 1.3.3,1.4 --with-valgrind
3.5.0

Thanks for the bug report!

I puzzled over your text for a while before I figured out what I think
the problem is -- I think the argument you've given to --with-valgrind
is the *source* tree for Valgrind. You actually want to give the
*installation* directory as the argument to --with-valgrind.

Indeed, I downloaded Valgrind 3.5.0 and installed it to
/opt/valgrind/3.5.0 and was able to build Open MPI
--with-valgrind=/opt/valgrind/3.5.0 --enable-memchecker with no
problems.

Can you could check that your --with-valgrind argument is actually the
installation directory, not the source directory?

On Feb 2, 2010, at 6:23 AM, Conboy, James wrote:

> Hi -
> configure failed the VALGRIND_CHECK_MEM_IS_ADDRESSABLE test,
> for openmpi-1.3.3 or -1.4 with Valgrind 3.5.0 -
> ....