Thanks for the bug report!
I puzzled over your text for a while before I figured out what I think the problem is -- I think the argument you've given to --with-valgrind is the *source* tree for Valgrind. You actually want to give the *installation* directory as the argument to --with-valgrind.
Indeed, I downloaded Valgrind 3.5.0 and installed it to /opt/valgrind/3.5.0 and was able to build Open MPI --with-valgrind=/opt/valgrind/3.5.0 --enable-memchecker with no problems.
Can you could check that your --with-valgrind argument is actually the installation directory, not the source directory?
On Feb 2, 2010, at 6:23 AM, Conboy, James wrote:
> Hi -
> configure failed the VALGRIND_CHECK_MEM_IS_ADDRESSABLE test, for openmpi-1.3.3 or -1.4 with Valgrind 3.5.0 -
> I ran configure with
> ! /bin/csh
> #! run configure
> ../configure --prefix=/home/pshare/lib/lf95/openmpi-Vg-1.3.3 \
> FC=`which lf95` F77=`which lf95` \
> --with-sge \
> --enable-debug \
> --enable-memchecker \
> --with-valgrind=/home/pshare/lib/source/valgrind-3.5.0 \
> --with-memory-manager=none \
> >& configure.log
> & the log ( attached ) ends with
> +++ Configuring MCA framework memchecker
> checking for no configure components in framework memchecker...
> checking for m4 configure components in framework memchecker... valgrind
> --- MCA component memchecker:valgrind (m4 configuration macro)
> checking for MCA component memchecker:valgrind compile mode... static
> checking --with-valgrind value... sanity check ok (/home/pshare/lib/source/valgrind-3.5.0)
> checking valgrind/valgrind.h usability... yes
> checking valgrind/valgrind.h presence... yes
> checking for valgrind/valgrind.h... yes
> checking for VALGRIND_CHECK_MEM_IS_ADDRESSABLE... no
> configure: error: Need Valgrind version 3.2.0 or later. Can not build component.
> Some valgrind header files are not where configure expects to find them ; to get this far, I added some links ..
> ./valgrind-3.5.0/include/valgrind/valgrind.h -> ../valgrind.h
> ./valgrind-3.5.0/memcheck.h -> memcheck/memcheck.h
> .. not a good omen, so no surprise it didn't work.
> [ See valgrind-3.5.0/NEWS :-
> - The location of some install files has changed. This should not
> affect most users. Those who might be affected:
> * For people who use Valgrind with MPI programs, the installed
> libmpiwrap.so library has moved from
> $(INSTALL)/<platform>/libmpiwrap.so to
> $(INSTALL)/libmpiwrap-<platform>.so. ]
> Configure tidies up in a very determined manner, so I don't have the files it used for the failing test. In any case, its likely that the problem is deeper than just some header files having moved around.
> I also downloaded Valgrind 3.2.1 from their archive, but couldn't configure this locally -
> checking the glibc version... unsupported version
> configure: error: Valgrind requires glibc version 2.2, 2.3 or 2.4
> >rpm -q glibc
> Persuading sysadmin to roll back to glibc 2.4 is not an option, so I'm stuck, for the time being. Are there other options I could use to configure 1.3.n or 1.4 with the latest valgrind, or can the --with-valgrind option be revived ??
> Thanks -
> Jim Conboy ( Culham Centre for Fusion Energy )
> users mailing list