Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] mpirun with WMI on Windows 7
From: Charles Shuller (charles.shuller_at_[hidden])
Date: 2010-02-02 12:56:46


The connection between nodes should be TCP/IP. I am currently using
Open MPI 1.4.1.

I've attached the output of ompi_info as a text file.

Thanks!

Charles
On 2/2/2010 11:46 AM, Shiqing Fan wrote:
>
> Hi Charles,
>
> It seems not a WMI problem, because the remote orted has already been
> launched, and only that part was done by WMI.
>
> What connection do you have between the nodes, tcp? Could you provide
> the version information of Open MPI, or just the output of ompi_info?
> so that I can take a close look.
>
>
> Thanks,
> Shiqing
>
>
> Charles Shuller wrote:
>> No messages on the command prompt.
>>
>> When I executed mpirun to launch notepad on the remote machine, It
>> crashes again.
>>
>> No information is ever printed to the command line unless I enter a bad
>> password.
>>
>> The very first time I attempt to use mpirun to launch a process on the
>> remote machine, I get an indefinite hang (I let it run for several hours
>> yesterday). Subsequently I get an abend dialog in about 3 seconds.
>>
>> My MPI application (Which just calls init and finalize) is at C:\bin
>> which is in the system path on both machines, this is also the bin
>> directory for the openmpi package.
>>
>> Is there anyway I can turn on logging, or do I need to go through and
>> insert debug statements myself and recompile?
>>
>>
>>
>> Thanks!
>>
>>
>> Charles
>>
>> On 2/2/2010 11:17 AM, Shiqing Fan wrote:
>>
>>> Hi Charles,
>>>
>>> On the local machine, which can be considered also as the "head node",
>>> no orted will be launched, the mpirun itself works as it locally.
>>>
>>> Did you see any error message on the command prompt? That would be
>>> very helpful.
>>>
>>> To do a simple test, just try to launch notepad on remote node: mpirun
>>> -np 1 -host host1 notepad.exe , and this will do the same thing as
>>> you run the wmic command line.
>>>
>>> If that works, it might mean that, you didn't copy your MPI
>>> application onto the remote node, which should present in the same
>>> path as on all working nodes, for example, on working nodes, your
>>> application could be placed at: D:\tests\app\app.exe (You have to do
>>> so, because the wmi impersonate level doesn't support network share
>>> yet. I'm still hacking on this to break the limit.). And then you can
>>> run the mpirun command line supplied with the application full path or
>>> directly run it under the application path.
>>>
>>>
>>> Regards,
>>> Shiqing
>>>
>>>
>>>
>>> Charles Shuller wrote:
>>>
>>>> Thanks Shiqing!
>>>>
>>>> Unfortunately, it still doesn't work, but I've got more info.
>>>>
>>>> I can use wmic to start an application on the remote machine, but
>>>> that application does not start in the current login process
>>>> (notepad.exe starts, but I have to ask task manager to show all
>>>> processes to find it, even though I'm currently logged in as the same
>>>> user). I believe this is expected behavior, please let me know if
>>>> it's not.
>>>>
>>>> When using mpirun, I can verify that orted starts on the remote
>>>> machine, but the crash or hang appears to happen before the
>>>> application starts execution. Oddly, orted does not appear to start
>>>> on the local machine. Logs all refer to mpirun crashing.
>>>>
>>>>
>>>> Cheers!
>>>>
>>>> Charles
>>>>
>>>> On 1/29/2010 2:56 AM, Shiqing Fan wrote:
>>>>
>>>>> Hi Charles,
>>>>>
>>>>> You don't need to install anything, but just a few security setting
>>>>> has to be correctly configured. Here are two links might be helpful
>>>>> (will be added into README.WINDOWS too):
>>>>> http://msdn.microsoft.com/en-us/library/aa393266(VS.85).aspx
>>>>> http://community.spiceworks.com/topic/578
>>>>>
>>>>> On the other hand, in order to check if WMI is working between the
>>>>> nodes, you can try with command:
>>>>>
>>>>> C:\>wmic /node:192.168.0.1 /user:username process call create
>>>>> notepad.exe
>>>>>
>>>>> the ip has to be the remote computer ip address, and the user name
>>>>> is which you use on remote computer. This command line will simply
>>>>> launch a non-interactive notepad (no GUI) on remote node using WMI,
>>>>> if it is successful, you should be able to see a notepad process in
>>>>> Task Manager or Process Viewer, and that also means mpirun will work
>>>>> through WMI.
>>>>>
>>>>> Could you check with the above command, and possibly tell me the
>>>>> return value, so that I can help you to make it work.
>>>>>
>>>>>
>>>>> Regards,
>>>>> Shiqing
>>>>>
>>>>>
>>>>> Charles Shuller wrote:
>>>>>
>>>>>> When attempting to launch an application on both local and remote
>>>>>> windows7 hosts, mpirun either hangs indefinately or abends.
>>>>>>
>>>>>> The application executes correctly on both machines, when only
>>>>>> launched
>>>>>> on a single host.
>>>>>>
>>>>>> I believe mpirun is using WMI, README.WINDOWS indicates that this
>>>>>> is the
>>>>>> case if I don't have the CCP toolkit and SDK installed, which I
>>>>>> don't. Additionally, I have encountered and resolved some security
>>>>>> issues
>>>>>> following this assumption.
>>>>>>
>>>>>> Any advice is welcome. I'm not married to WMI, so if the
>>>>>> solution is
>>>>>> "install something else" I'm great with that.
>>>>>>
>>>>>>
>>>>>> Thanks!
>>>>>>
>>>>>> Charles
>>>>>> _______________________________________________
>>>>>> users mailing list
>>>>>> users_at_[hidden]
>>>>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>>>>>
>>>>>
>>>
>>
>>
>
>