Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problem with HPL while using OpenMPI 1.3.3
From: ilya zelenchuk (ilya_at_[hidden])
Date: 2010-01-05 09:23:00


Happy New Year, Gus!
Yes, I'm using affinity. This is my openmpi-mca-params.conf file:

---
# Use RSH instead SSH
pls_rsh_agent=rsh
# Turning on processor affinity
mpi_paffinity_alone=1
# Include using eth1.
btl_tcp_if_include=eth1
# Exclude using lo and eth0.
btl_tcp_if_exclude=lo,eth0
---
I rebuild openmpi-1.3.3 from tar and find something interesting.
If i build with this options:
CC=icc CXX=icpc F77=ifort FC=ifort ./configure
--prefix=/opt/testing/default/openmpi-1.3.3/ --disable-ipv6
All work's fine!!!
But if I use:
CC=icc CFLAGS=" -O3" CXX=icpc CXXFLAGS=" -O3" F77=ifort FFLAGS=" -O3"
FC=ifort FCFLAGS=" -O3" ./configure
--prefix=/opt/testing/tuning/openmpi-1.3.3/ --enable-debug
--enable-mpi-threads --disable-ipv6
Then I get errors.
What you think?
Now I'm starting to investigate, what options cause OpenMPI broken.