Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Cannot get OpenMPI 1.3.3 to work with Torque 2.4.2
From: pat.o'bryant_at_[hidden]
Date: 2010-01-05 07:29:50


I believe the problem is a missing "#" character. So, the correct way to
specify aTorque/PBS parameter is:

#PBS -N Test

Since you specified "PBS -N Test" you are getting the message "PBS" not
found. "PBS" is being interpreted as a command and not a parameter.

J.W. (Pat) O'Bryant,Jr.
Business Line Infrastructure
Technical Systems, HPC

                                                                           
             Ralph Castain
             <rhc_at_open-mpi.
             org> To
             Sent by: Open MPI Users <users_at_[hidden]>
             users-bounces@ cc
             open-mpi.org
                                                                   Subject
                                      Re: [OMPI users] Cannot get OpenMPI
             01/04/10 11:50 1.3.3 to work with Torque 2.4.2
             PM
                                                                           
                                                                           
             Please respond
                   to
             Open MPI Users
             <users_at_open-mp
                 i.org>
                                                                           
                                                                           
                                                                           
                                                                           

I suggest you contact the Torque user list about this - it is a Torque
configuration issue, not something to do with OMPI.

On Jan 3, 2010, at 10:49 PM, chih lee wrote:

      Hello,

      I followed the instructions on the FAQ page to configure and compile
      openmpi so that it should work with Torque.
      ./configure --with-tm=/usr/local --prefix=/usr/local
      The option --disable-server was used to configure torque on the
      compute nodes.
      I got openmpi compiled without any error message on the head and
      compute nodes.

      I can use
      $ mpirun -np 2 --host node1,node2 a.out
      to run parallel programs without any problem.

      However, when I submit the following script with qsub

      ____________________________________________________________________
      #!/bin/sh
      #
      PBS -N Test
      PBS -o /home2/user2/test.sh.o
      PBS -l nodes=8
      mpirun /home2/user2/a.out # a.out simply prints out # of procs and
      its ID
      ____________________________________________________________________

      I got the following output and error messages.

      Output:
      N. of procs = 1, proc ID = 0

      Error messages:
      /var/spool/torque/mom_priv/jobs/198.my_head_node.SC: 3: PBS: not
      found
      /var/spool/torque/mom_priv/jobs/198.my_head_node.SC: 4: PBS: not
      found
      /var/spool/torque/mom_priv/jobs/198.my_head_node.SC: 5: PBS: not
      found
      /var/spool/torque/mom_priv/jobs/198.my_head_node.SC: 6: PBS: not
      found
      /var/spool/torque/mom_priv/jobs/198.my_head_node.SC: 7: PBS: not
      found
      /var/spool/torque/mom_priv/jobs/198.my_head_node.SC: 8: PBS: not
      found

      I'm new to OpenMPI and Torque. I really appreciate it if you can give
      me some insights. Thanks!

      Best,
      Steve

      _______________________________________________
      users mailing list
      users_at_[hidden]
      http://www.open-mpi.org/mailman/listinfo.cgi/users
_______________________________________________
users mailing list
users_at_[hidden]
http://www.open-mpi.org/mailman/listinfo.cgi/users