Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Problem compiling 1.4.0 snap with PGI 10.0-1 and openib flags turned on ...
From: Gus Correa (gus_at_[hidden])
Date: 2009-12-29 16:18:40


Hi Richard

I haven't upgraded from PGI 8.0-4, so no comments on PGI 10.

As for IB, I configured OpenMPI only with the --with-openib flag,
but not --enable-openib-ibcm.
Have you tried that?

Gus Correa
---------------------------------------------------------------------
Gustavo Correa
Lamont-Doherty Earth Observatory - Columbia University
Palisades, NY, 10964-8000 - USA
---------------------------------------------------------------------

Richard Walsh wrote:
> All,
>
> Not overwhelmed with responses here ... ;-) ... No one using PGI 10.0 yet?
> We need it to make use of the GPU compiler directives they are supporting.
> Can some perhaps comment on whether this is the correct way to configure
> for an IB system? Everything works with Intel and/or if I compile without the
> IB flags.
>
> Sent the same report to PGI, but seems like the support team there is on
> break for the Holidays.
>
> Someone else must have seen this as well ... No ... ??
>
> rbw
>
> Richard Walsh
> Parallel Applications and Systems Manager
> CUNY HPC Center, Staten Island, NY
> 718-982-3319
> 612-382-4620
>
> Mighty the Wizard
> Who found me at sunrise
> Sleeping, and woke me
> And learn'd me Magic!
> ________________________________________
> From: users-bounces_at_[hidden] [users-bounces_at_[hidden]] On Behalf Of Richard Walsh [Richard.Walsh_at_[hidden]]
> Sent: Saturday, December 19, 2009 12:18 PM
> To: users_at_[hidden]
> Subject: [OMPI users] Problem compiling 1.4.0 snap with PGI 10.0-1 and openib flags turned on ...
>
> All,
>
> Succeeded in overcoming the 'libtool' failure with PGI using
> the patched snap (thanks Jeff), but now I am running
> into a down stream problem compiling for our IB clusters.
> I am using the latest PGI compiler (10.0-1) and the 12-14-09
> snap of OpenMPI of version 1.4.0.
>
> My configure line looks like this:
>
> $ ./configure CC=pgcc CXX=pgCC F77=pgf77 FC=pgf90 --enable-openib-ibcm --with-openib \
> --prefix=/share/apps/openmpi-pgi/1.4.0 --with-tm=/share/apps/pbs/10.1.0.91350
>
> The error I get during the make at about line 8078 is:
>
> libtool: compile: pgcc -DHAVE_CONFIG_H -I. -I../../../../opal/include -I../../../../orte/include -I../../../../ompi/include -I../../../../opal/mca/paffinity/linux/plpa/src/libplpa -I../../../.. -D_REENTRANT -O -DNDEBUG -c connect/btl_openib_connect_xoob.c -fpic -DPIC -o connect/.libs/btl_openib_connect_xoob.o
> source='connect/btl_openib_connect_ibcm.c' object='connect/btl_openib_connect_ibcm.lo' libtool=yes \
> DEPDIR=.deps depmode=none /bin/sh ../../../../config/depcomp \
> /bin/sh ../../../../libtool --tag=CC --mode=compile pgcc -DHAVE_CONFIG_H -I. -I../../../../opal/include -I../../../../orte/include -I../../../../ompi/include -I../../../../opal/mca/paffinity/linux/plpa/src/libplpa -I../../../.. -D_REENTRANT -O -DNDEBUG -c -o connect/btl_openib_connect_ibcm.lo connect/btl_openib_connect_ibcm.c
> libtool: compile: pgcc -DHAVE_CONFIG_H -I. -I../../../../opal/include -I../../../../orte/include -I../../../../ompi/include -I../../../../opal/mca/paffinity/linux/plpa/src/libplpa -I../../../.. -D_REENTRANT -O -DNDEBUG -c connect/btl_openib_connect_ibcm.c -fpic -DPIC -o connect/.libs/btl_openib_connect_ibcm.o
> PGC-S-0040-Illegal use of symbol, __le64 (/usr/include/linux/byteorder/little_endian.h: 43)
> PGC-W-0156-Type not specified, 'int' assumed (/usr/include/linux/byteorder/little_endian.h: 43)
> PGC-S-0039-Use of undeclared variable __le64 (/usr/include/linux/byteorder/little_endian.h: 45)
> PGC-S-0104-Non-numeric operand for multiplicative operator (/usr/include/linux/byteorder/little_endian.h: 45)
> PGC-S-0040-Illegal use of symbol, __le64 (/usr/include/linux/byteorder/little_endian.h: 47)
> PGC-S-0040-Illegal use of symbol, __be64 (/usr/include/linux/byteorder/little_endian.h: 67)
> PGC-W-0156-Type not specified, 'int' assumed (/usr/include/linux/byteorder/little_endian.h: 67)
> PGC-S-0040-Illegal use of symbol, __be64 (/usr/include/linux/byteorder/little_endian.h: 69)
> PGC-W-0156-Type not specified, 'int' assumed (/usr/include/linux/byteorder/little_endian.h: 69)PGC-S-0040-Illegal use of symbol, __be64 (/usr/include/linux/byteorder/little_endian.h: 71)
> PGC-W-0156-Type not specified, 'int' assumed (/usr/include/linux/byteorder/little_endian.h: 71)PGC/x86-64 Linux 10.0-1: compilation completed with severe errors
> make[2]: *** [connect/btl_openib_connect_ibcm.lo] Error 1
> make[2]: Leaving directory `/export/apps/openmpi-pgi/1.4.0/build/ompi/mca/btl/openib'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/export/apps/openmpi-pgi/1.4.0/build/ompi'
> make: *** [all-recursive] Error 1
>
> Compilation with the latest Intel compilers and these 'openib' options completes
> without issue.
>
> Are my configure options for 'openib' correct? Has anyone else see this?
>
> Thanks much,
>
>
> Richard Walsh
> Parallel Applications and Systems Manager
> CUNY HPC Center, Staten Island, NY
>
> Mighty the Wizard
> Who found me at sunrise
> Sleeping, and woke me
> And learn'd me Magic!
>
> Think green before you print this email.
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> Think green before you print this email.
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users