Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] [visit-developers] /usr/bin/ld: cannot find -lrdmacm on 9184
From: tom fogal (tfogal_at_[hidden])
Date: 2009-12-15 23:11:57


Simon Su <newsgroup4ssu_at_[hidden]> writes:
> Hi Tom,
>
> I am using the standard openmpi package that run on all the cluster
> machines here at Princeton. So, maybe I shouldn't touch openmpi. But,
> removing -lrdmacm from the MPI_LIBS line in the machinename.conf file
> worked. Any implication from doing this?

The only thing it could possibly do is disable RDMA for you. However,
since removing it did not produce any undefined symbol errors, my guess
is that your OpenMPI isn't using RDMA anyway.

There might be an OpenMPI bug here, though. I've cc'd the OpenMPI
community to see if they have any input. As a summary for them: Simon
is trying to build our MPI-enabled application. A script which tries
to automate this adds the output of "mpic++ -show". His build then
failed because it attempted to link against librdmacm, which does not
exist in his normal search paths (or maybe at all). Is it possible
that `mpic++ -show' includes/adds "-lrdmacm" even when OpenMPI is not
itself using the library?

Thanks,

-tom

> On Tue, Dec 15, 2009 at 8:46 PM, tom fogal <tfogal_at_[hidden]> wrote:
>
> > Simon Su <newsgroup4ssu_at_[hidden]> writes:
> > > I am getting this error message while building 9184.
> > [snip]
> > > -lz -lm -ldl -lpthread -L/usr/local/openmpi/1.3.3/gcc/x86_64/lib64
> > > -lmpi_cxx -lmpi -lopen-rte -lopen-pal -lrdmacm -libverbs -lnuma -ldl
> > -lnsl
> > > -lutil -lm -lcognomen \
> > > -L/usr/local/openmpi/1.3.3/gcc/x86_64/lib64 -lmpi_cxx -lmpi
> > > -lopen-rte -lopen-pal -lrdmacm -libverbs -lnuma -ldl -lnsl -lutil -lm
> > > -lcognomen
> > > /usr/bin/ld: cannot find -lrdmacm
> > > collect2: ld returned 1 exit status
> >
> > Your OpenMPI install (incorrectly?) thinks it has librdmacm available,
> > but the library isn't in your search path.
> >
> > It apparently defaults to enabled in 1.3.3. That seems rather
> > silly, since I imagine the library requires RDMA hardware, which
> > is of course not ubiquitous. Anyway, try configuring OpenMPI with
> > --disable-openib-rdmacm and then rerunning build_visit.
> >
> > Of course, if you actually have an RDMA cluster, you'll want to delve
> > deeper.
> >
> > Cheers,
> >
> > -tom