Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Problem building OpenMPI with PGI compilers
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2009-12-10 10:20:32


On Dec 9, 2009, at 4:36 PM, Jeff Squyres wrote:

> That's the commit message for r22273. Also see the commit message for r22274 (https://svn.open-mpi.org/trac/ompi/changeset/22274).
>
> Meaning: the fix is now in the SVN trunk; it hasn't migrated over to the v1.4 and v1.5 branches yet. It's an autogen.sh fix -- you should be able to download autogen.sh from our SVN trunk and run it on your 1.4 tree.

Actually, I was wrong. You *can't* just take the SVN trunk's autogen.sh and use it with a v1.4 tarball (for various uninteresting reasons).

Given that we haven't moved this patch to the v1.4 branch yet (i.e., it's not yet in a nightly v1.4 tarball), probably the easiest thing to do is to apply the attached patch to a v1.4 tarball. I tried it with my PGI 10.0 install and it seems to work. So -- forget everything about autogen.sh and just apply the attached patch.

Sorry for the confusion!

-- 
Jeff Squyres
jsquyres_at_[hidden]